All firefox add-ons disabled ( SOLVED )

Hi!

Yesterday I installed the antivirus and firewall software and after doing that all my add-ons in firefox are disabled, i.e the do not show up in the toolbars. Is it the firewall or the antivirus software that does this and how do I get them to show up in the toolbars again?

Got an idea right after I had posted this one and I solved it!

  1. Manually go to tools/add-ins and disable each of your plug-ins, then restart FireFox.

  2. Manually activate each of your plug-ins again and restart FireFox, now the plug-ins should be back in business.

Another problem I had was that HIPS asked me about FireFox every time and didn’t remember the answer I gave (very annoying) so I just excluded it in the HIPS settings for the antivirus software (same as safe I guess)… and that stopped it from bugging me with questions all the time.

I also had a problem with the firewall not remembering my answers for FireFox either and that I solved by following the recommendation in this post:

http://www.tweakforce.com/modules.php?name=Forums&file=viewtopic&t=758

and removing the existent rule and manually making a rule for FireFox EXCEPT that I copied the rule for Internet explorer so FireFox got the same rule and now the firewall don’t ask me any question about FireFox either and so far it seems to work as good as with IE:-))

I can’t seem to post to the existing thread on this, but I followed the advice given - ie disable addons, start firefox again, enable them.

Whenever I disable the addons and restart firefox, they are still set to enabled. And I have lost the use of all the add-ons that I love so much.

I have tried defining firefox as a safe/trusted application - no difference.

I have uninstalled firefox and re-installed it - no difference.

I like Comodo, and would rather use it that a microsoft product etc, and I would like to recommend it to others, but since most of my friends and colleagues like their firefox add-ons, I won’t at this stage.

It seems to be a common problem …

By the way, thanks for a great product, don’t mean to seem ungrateful. Also, I am new to posting etc, and apologise if I’m in the wrong place, or following the wrong procedure

I moved this topic to a correcter place :slight_smile:

I’m not really calling this a solved problem, did you check your defense+ and Firewall logs ? Is Firefox a trusted, allowed application or webbrowser application ?

If this keeps continuing, try Opera :slight_smile:

Xan