"All Applications" group is not working

Steps to reproduce:

  • delete all application rules under “Network security policy”, leave default global rules;
  • add iexplore.exe, firefox.exe to application rules with predifined policy “web browser”;
  • add “All applications” group with “allow IP out any any” as the last entry under application rules of “Network security policy”.
  • apply everywhere;
  • set Firewall to “Custom” mode;

Any outgoing connections of any apps are blocked silently until Firewall is set to “Disabled” mode.

Comodo Firewall v3.12
Windows XP Pro SP2 x32
Administrator user account