Alerts when printing

When I try to print from various applications (Firefox, MS Word, etc.) I always get an alert from D+. Even if I set it to remember my action when I allow it in the alert window I still get prompted.

It seems to happen because C:\WINDOWS\system32\spool\PRINTERS\ is a protected area and the applications create files in there with random names every time they print. If I allow the action, then a specific rule is added with the specific random name which the application won’t create again, it will use a different file name next time.

What is the proper way to fix this and shouldn’t Comodo just be smart about it?

Almost all this random names starts with single prefix or/and extention. Look for this and try to see equal parts. After than Create a Rule with wildcards =)

But where do I create this rule? For every application that needs to print? Is there a way to do it globally to allow printing?

Try this:

D+ > Advanced > Computer Security Policy

For each app you want to be able to print with (e.g. FF, Word, etc), go to that executable’s access rights and navigate to “Protected Files/Folders”. Choose the “Modify” button and add the path “C:\WINDOWS\system32\spool\PRINTERS” to the “Allowed Files/Folders”.



Can’t Comodo just fix this?? I hope they don’t expect every user to go through this just to allow printing … it’s such basic functionality, they should have some sort of shortcut setting “allow printing”.

That’s part of a HIPS program. There may be some common sense alerts, but D+ is doing its job. COMODO is currently researching on usability and less pop-ups and have already started improving. :slight_smile:

BTW, you’re the first person I’ve seen with this printing problem anyway. I don’t think it’s common.

I have this also,

You can put this in protected/files


Surprised nobody else is using print spooling. Or maybe people just don’t complain about the alerts, they just keep hitting allow on each print job …

Well this thread got unnecessarily confusing and went nowhere fast.

How about starting with.
What OS are you using?
What mode do you have D+ set on?
Have you added files to my protected files?

With none of the above answers I can say you should.
Get rid of Pending files if you have any.
Purge the Computer Security Policy area, remember to apply.
Purge My Protected Files area, apply.
Put D+ in Training Mode.
Print, Print, Print with every app that you would print from.
Chill out, Reboot even.
Print some more.
Put D+ in Safe Mode.

If still no joy, cross that bridge when you get there.

What mode have CIS set at Safe Mode or PC Clean?

Clean PC Mode on XP Pro SP3 32-bit

CleanPC XP Pro SP2
Using print spooling and… just hit Allow every time =)