Alerts and rules generated for javaw.exe instead of java applications [M1435]

A. Alerts and rules generated for javaw.exe and not the individual java applications run
Can you reproduce the problem & if so how reliably?:
Yes, on both of my machines every time I run any java application (Trusted, untrusted and self-written on the same host).
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Install java 7/8, both x86 and x64 (I have not tried a clean install of java x64 but have uninstalled x86 and updated java x64 afterwards)
2: Run any java application which triggers an access alert (such as network access) from cmd
One or two sentences explaining what actually happened:
An alert for the javaw.exe process was generated (C:\Program Files\Java\jre8\bin\javaw.exe).
One or two sentences explaining what you expected to happen:
An alert for the .java file running is generated, the same way as if it had been launched by double clicking it in explorer.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Yes, but none of them are applicable since the sandbox is not involved.
Any software except CIS/OS involved? If so - name, & exact version:
Java x86/x64, any version beyond 7
Any other information, eg your guess at the cause, how you tried to fix it etc:
My guess regarding the cause is that Comodo fails to identify the javaw.exe as a host for java applications similar to java.exe. Comodo seems not to check which executable is associated with running .java files.

B. YOUR SETUP
Exact CIS version & configuration:
8.1.0.4426 (and some previous versions)
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
D+/HIPS: Paranoid
Autosandbox/BBlocker: Tested both enabled and disabled
Firewall: Custom ruleset
AV: Not installed
Have you made any other changes to the default config? (egs here.):
Added any global rules or safe zones manually
Not using Comodo DNS servers
Cloud disabled
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Yes (Pc1), No (Pc2)
if so, have you tried a a a clean reinstall - if not please do?:

Have you imported a config from a previous version of CIS:
Yes (Pc1), No (Pc2)
if so, have you tried a standard config - if not please do:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 SP1, 64 bit, UAC disabled, admin/user, no
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Bitdefender(Pc1),MSE(Pc2) b=Avast (Tested with avast also)

[Editied 2015-02-24 to clarify steps to reproduce]

Please export your configuration & attach a sample.

Thank you.

Attached are screen shots showing alerts when:

A: Running .jar file from explorer
B: Running .jar file from cmd

I tried the following commands, which resulted in the same behaviour:


"C:\Program Files\Java\jre 1.8.0_25\bin\javaw.exe" -jar "C:\Program Files (x86)\Tools\DirSyncPro\dirsyncpro.jar"
java -jar "C:\Program Files (x86)\Tools\DirSyncPro\dirsyncpro.jar"
javaw -jar "C:\Program Files (x86)\Tools\DirSyncPro\dirsyncpro.jar"

The current configuration of PC1 is attached also.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

@`-Wins-´, PM sent.

Please check if it’s fixed in version <8.2.0.4703>.

Thank you.

Should be fixed with CIS 8.2.0.5005 so moving to resolved. If you feel this is not fixed please PM a moderator. Thanks.