Alcohol 120 does not run - BSOD - NOT a guardxx.dll issue [Issue: #256]

The bug/issue

  1. What you did:
    Launching alcohol 120%
  2. What actually happened or you actually saw:
    Now produces “loading alcohol device drivers failed! emulation options and native driver interface will not be available” error, also, attempting to reinstall alcohol produces “internal setup error. contact support” error
  3. What you expected to happen or see:
    normal launch
  4. How you tried to fix it & what happened:
    Disabling Defense+ permanently then restarting fixes the problem. Also note that after alcohol’s errors, before I was able to issue the actual restart, the system eventually crashed with a bugcheck posted in the appropriate thread. https://forums.comodo.com/moderator-verified-issue-reports-cis/alcohol-120-does-not-run-not-a-guardxxdll-issue-issue-256-t61889.0.html;msg439218#msg439218 I believe they should be paired since they seem related.
  5. Details (exact version) of any software involved with download link:
    Alcohol 120% version 2.x, tried different builds all installers produce error now
  6. Bugzilla id (mods use only):

Files appended

  1. Screenshots illustrating the bug:
  2. Screenshots of related event logs or the active processes list:
  3. A CIS config report or file:
  4. Crash or freeze dump file: https://forums.comodo.com/bug-reports-cis/bsods-please-add-your-minidump-files-here-cis-v5x-t26981.0.html

Your set-up

  1. CIS version & configuration used:
    CIS 5.x
  2. Whether you imported a configuration, if so from what version:
    Version 4.x
  3. Defense+ and Sandbox OR Firewall security level:
    Irrelevant, either does not affect end result.
  4. OS version, service pack, no of bits, UAC setting, & account type:
    Windows 7 x64, UAC off, admin account
  5. Other security and utility software running:
    Avira antivirus
    6096

Try to put it as Exclusion in D+ Settings/Execution Control Settings.

I doubt it has anything to do with it since the alcohol installer, a sepparate program, also gives the error. My biggest guess is that since the system also crashed it’s conflicting with its common, low-level component, SPTD. Also disabling D+ permanently fixed it for now.

Ah sorry I’ve missed that part with installer. :-[
Anyway I’m very happy with Virtual Clone Drive. No conflicts, light and is doing whatever Daemon Tools/Alcohol 120 is doing.

Except 21 virtual drives.

THanks for this bug report.

I’d be tempted to try what burebista suggests, with one twist:

  1. Add all the executable files in the programs directory to buffer overflow exemptions - this removes gurad32/64.dll as well as BO protection
  2. Make all the executable files, including the installer, installer/updaters in the CSP

If this does not fix maters I’ll forward the buug as verified tomorrow if you add screenshots of at least one of your errors if you can without provoking a new BSOD. Accordingly I’d also appreciate it if you would include the appended file checklist. Just copy and paste.

Best wishes, and many thanks for following the format

Mouse

I too am interested in the results, Searinox.
My son has similar issues with a virtual drive (didn’t say which one), won’t believe me when I say this may be an easy fix (he would not try this suggestion).

Thank you for your time.

It does not fix it. And as such back to my point, it’s most likely bumping into the SPTD driver. Also I don’t see why I have to try a workaround BEFORE you submit a bugreport. All software should idealy not conflict with comodo at all, and one conflict suggest there’s something broken from v4 to v5. Very troubling argument you used there.

Thanks for trying the approach I suggested.

The reason for trying this before submitting a bug report is to gather as much information as possible before passing the problem on to developer. If the BO exclusion had solved the problem, it would have given the devs a very good idea about the source of the problem.

This saves their time, and, because CIS is free, development time is limited. In turn this means that this, or other bugs are more likely to get fixed. Conflicts with specific programs do not get the same level of priority as general bugs, so everything you can do to make things easier improves the likelihood of a fix.

With this in mind I’d deeply appreciate it if you would append screenshots of the errors you received - at least of the one that did not cause the BSOD, and add the appropriate section to the report format back in, by editing the post. Screenshots of you APL and Defense plus logs may help as well. If you have insights regarding what is causing this, please do add them, as I know that you are technically experienced, indeed I think it was you that helped me to understand how CIS (was) identifying files.

I’d also very much appreciate it if you would try the suggested work-around with Avira completely disabled, just in case. (As explanation, if Avira’s real time facilities are enabled there will be two AV hooks into every executable, and this may cause instability in utility programs).

Incidentally - I’ll ask because I guess you have tried it already - does this work if you rename guard32/64.dll in all relevant locations and reboot? The BO exclusion is supposed to prevent injection of guardxx.dll, and it would be good for mods to know if that is working, so we can predict what other programs CIS 5 will conflict with.

Hope this explains things a bit better. (BTW all us mods are volunteers - none of us work for Comodo).

Best wishes and many thanks in anticipation

Mike

Renaming guard drivers has solved similar problems for me with the initial release of version 4. It is the next best bet. I will try it.

Thanks for the moment I found your BSOD report, and so have linked this into your first post. This gives you the prompts for any screenshots you may add.

I can’t install Alcohol 120 with COMODO FW installed. I uninstalled COMODO and voila, install without problems.
I think suggest another virtualization software ihelps to solve the problem.
I like COMODO FW and Alcohol 120, and i want istall both programs, not Virtual clone drive or whtever shit program.

Hi Searingnox

Did this work?

Best wishes

Mouse

No it does NOT work. I removed guard32 from syswow64 and guard64 from system32 and reactivated D+. This does not appear to be a problem with the Guard component of Defense+, but rather with the D+ itself. And again, D+ security level doesn’t matter, even if set to Disabled. The D+ driver merely needs be loaded into the OS to break alcohol.

For the third time - other virtual drive software do not provide the lowlevel emulation that D-Tools and Alcohol have, and I NEED that so I will not switch to another software. Also I need lots of these virtual drives, and only alcohol can emulate 20+. And my final point - it was working with v4 and no longer works with v5. Why should it be the user’s responsibility to remove a software that was broken by a newer version of something else?

I’m having the same problem.

Virtual drives stopped working after upgrade to cis5, tried uninstalling/reinstalling, uninstall worked fine, however refuses to reinstall (any version of alcohol). SPTD installer also works, so problem is somewhere else.

(Why can’t these posts be edited?) Anyway, permanently disabling D+ works, but disabling any part does not work, nor does giving services.exe more rights. No exclusions/blocks listed there either, nor were there any entries added to the defense+ events logs. File (installer and all relevant program files) are ‘trusted’, but the installer still refused to execute with D+ enabled in any way, so I imagine some sort of check is built into that installer, as it doesn’t try to install anything yet by the time it refuses to continue.

BSOD report as submitted by Searingox, reposted by Mouse:

Windows Version/Bit and Service Packs

Windows 7 64bit

Your realtime Antivirus/version,Spyware remover/Version, other Security Software/Version

Comodo and Avira Free

Affected Driver/Software and Version (if the bug doesn’t affect window itself)

Comodo 5.x

Brief description of the problem (Attach Diagnostic report or crash dumps)

Encountered a conflict with Alcohol 120% in the new version 5 of comodo as described here https://forums.comodo.com/bug-reports-cis/alcohol-120-conflict-with-version-5-t61889.0.html;msg436071#msg436071 As normal procedure, I ticked “deactivate defense+ permanently” since it is the most common cause of such issues. However, as I was closing down messengers in preparation for a restart, the system crashed. Note that disabling D+ also proved to fix the conflict.

[attachment deleted by admin]

I have the exact same problem! After installing COMODO Firewall v5 Alcohol 52% virtual drives stopped working. At first I didn’t make the connection and thought there might have been something broken with Alcohol 52% so I uninstalled it, downloaded the latest version (Alcohol52 FE 2.0.1.2033) and tried to install it, and then I got this error “Internal Setup Error. Contact Support.”, and I could not proceed. Permanently disabling D+ seems to have done the trick and I was able to install Alcohol 52% and it’s now working fine.

Any solution to this issue from the COMODO devs? Or do I just have to leave D+ permanently disabled for now?

Follow My app doesn’t seem to work with CIS - should I post a bug report? to see if filing a bug report is the way to go.