aim disconnect [Resolved]

does anyone have problems with AIM (AOL IM) disconnecting while using comodo?

I use Gaim and I can no longer use CFP until the Vista-compatible V3 version comes out, so I don’t have any personal experience, but I know a lot of people who use the two without any problems.

Does CFP give any warning? Does AIM give any notice? Does it do it immediately or after x number of minutes? Are any components blocked in the Component Monitor? Any applications in the Application Monitor?

CFP doesn’t give warning as to pertain to any connection attemps…AIM will just D/C then reconnect automatically and funny thing is when I disabled and closed out CPF…the connection issues with aim ceased and fine…

How long is it between AIM’s D/Cs and then R/Cs?

couple secs@most…since my internet connection ITSELF is working aim automatically R/C…it’s as if only aim is d/c and the rest of my 'net is working but since i’ve disabled CPF…no dc/rc issues…fix for this? as I’ve seen so many good reviews and heard good things on Comodo i’d hate to hafta uninstall it (R)

May I please have a screenshot of your network rules?

come again? ??? lol


You can do the following:

Make a note of the time of AIM’s disconnect. Then go to Activity/Logs, and check for an entry at that same time. There should be an entry; probably either Component Monitor or Application Behavior Analysis. Shouldn’t be Network Monitor, as it is connecting, so the rules there are probably ok. Shouldn’t be Application Monitor, as it’s allowed there or it wouldn’t be able to connect.

I’m guessing you’ll see it’s related to ABA. That being said, you can go to the AppMon entry for AIM, open the rule and go to the Miscellaneous tab. Click the box, “Skip Advanced Security Checks” then OK. A reboot will clear the memory and reset the updated rule.

Hope this helps,


thanks LM, couple questions 1)what’s ABA stand for? 2) how do I take a screenshot of my network rules? I know how to take a SS but where are the network rules located?

Application Behavior Analysis = ABA.

Network Monitor in CFP - Security/Network Monitor (or just select Network Monitor from the Summary Page of the firewall application window). However, you may not need to capture the SS of the NM just yet.

Follow my suggestion, then let’s see where we stand. :wink:


LM, could you please post (in detail) how to do this exactly, as I’ve tried and can’t figure it out for the life of me sorry…

No problem, here’s the steps to take:

  1. Open and attempt to use AIM. Note the time when it gets disconnected.
  2. In Comodo FW, go to Activity tab and select Logs (on the side).
  3. Right-click a log entry, and select “Export HTML” from the context menu. Save the file so you know where it is.
  4. Open the exported HTML log file; it will show up in your browser.
  5. Highlight the information showing, around the time that AIM got disconnected.
  6. Right-click this highlighted info and select “Copy.”
  7. Start a reply post here.
  8. Right-click within the text window and select “Paste.”
  9. If your personal/external IP address shows up in the logfile text (which it probably will), you may mask it out with “x”, such as: if it was, you could change that to

Now your relevant log entries are here where we can see more of what is happening. Then we’ll take the next step from there. Sorry if any of what I’ve said before is confusing. Sometimes I think ahead of myself, and it doesn’t make much sense. :wink:


no problem LM, here you go:Date/Time :2007-03-07 15:35:47Severity :MediumReporter :Network MonitorDescription: Outbound Policy Violation (Access Denied, Protocol = IGMP)Protocol:IGMP Outgoing Source: Destination: Reason: Network Control Rule ID = 5
the d/c happened around today 3:35pm (15:35 militarty time :D)
EDIT:also LM, I tried your suggestion of “Click the box, “Skip Advanced Security Checks” then OK. A reboot will clear the memory and reset the updated rule.” and that didn’t work just to let you know:)

Some IM apps use IGMP protocol, such as your log is referencing. You can try to see if that will fix it, by adding a Network Monitor rule to allow it outbound.

It would look like this:

Action: Allow
Protocol: IP
Direction: Out
Source: Any
Destination: Any
IP Detail: IGMP

Make sure that you move the rule up above the bottom Block & Log All rule (currently Rule ID 5), or it will continue to be blocked.

See if that does it…


no idea how to do that LM, could you explain how to in detail like before that you did so good on ;D

Okay, here goes… :wink:

  1. Open CFP GUI (user interface) from systray icon
  2. Click on “Network Monitor” link from Summary page, or go to Security/Network Monitor
  3. Click the very last/bottom rule, which is “Block & Log, IP In/Out” to highlight that rule
  4. Right-click that last rule, and from the context menu, select Add Rule, then Add Before
  5. In the dialog box that opens, input the following, respectively:

Action: Allow
Protocol: IP
Direction: Out
Source IP: Any
Destination IP: Any
IP Details: IP Protocol: IGMP

Then click “OK.”

This will place the rule in the Network Monitor; make certain that it is indeed placed above/before that bottom Block & Log IP In/Out rule, or it will be blocked. It should be, but you want to make sure… if for some reason it turned up below that Block rule, putting it in last place, simply:

  1. Click on the rule to highlight it
  2. Click on the “Move Up” icon at the top of the Network Monitor until the rule is positioned above the Block IP In/Out rule.

Now close the GUI (application interface window), and reboot your computer. This clears out the previous ruleset from memory and “sets” the new one.

Then try AIM and see if it works properly, without disconnects…


thanks again for the detailed instructions LM appreciate it :slight_smile: I did it and so far so good…I’ll keep you posted

Here’s hoping it works…

Do let us know, so we can mark the topic resolved for other users’ benefit if we’re good to go.


worked great LM again thanks ALOT! far no DC (due to CPF) ;D

Great news, jmoney3457! I will mark the topic resolved then. If you experience an issue with this and need the topic reopened, just PM me or another Mod with a link and we’ll be glad to do so.