After uninstall certain programs still can't use internet

I used Comodo for a while, but I experienced some problems with Limewire, Steam and other programs. I tried to solve them with the tutorials in this forum, but it didn’t work, Limewire couldn’t even start. So I decided to uninstall Comodo. After I rebooted, those programs still don’t work. I’m very sure Comodo caused this because I’ve been using those progs for a long while. The problems started when I installed COmodo. Any help on how I can solve this issue. I tried searching the forums but didn’t find anything useful.
I tried reinstalling it and then setting it to allow everything but that didnt work. I tried manually opening ports, deleting all registry entries about comodo but still those progs are blocked


I solved the issue.
It seems that Comodo changed my internet security settings on install. But it didn’t change it back after uninstall. So setting your security settings back to default solves this issue. In case anyone has the same problems try this.

Please, help me… im with the same problem.

What changes have you done, exactly?