After installing firewall v all smtp traffic is blocked

After installing firewall v all outgoing smtp traffic is blocked. I am using Firetrust Mailwasher Pro v6 (anti spam), and as my standard mail program i am using Outlook 2007.

Receiving from the pop servers is no problem, but sending does not work for me. Everything looks normal but somehow port 25 get blocked as soon as the firewall is installed. Just turning off the firewall or exit the progam completely does not help.

The only option is uninstalling it. To bad because v2.4 was doing just fine. but sins v3 is automatically installed by the program i had to remove the firewall completely to get the mail send.

What i use:

Windows XP SP2 (Dutch) fully updated.
Prescott dual P4 at 3.2 GHz
4096 MB DDR Ram

Running in the background:
Webroot Spy Sweeper Pro 4.5 (without antivirus) fully updated.
BOclean 4.25.
Verification Engine (latest).
NOD32 antivirus (latest) fully updated.

Anyone having the same problem solved?

tnx, Z. :wink:

I just updated Comodo to version and I can’t check my mail with either Outlook 2003 or Mail Washer Pro.

Have you found any answers??

Spy Sweeper is the program blocking your email. Bring up Spy Sweeper. Go to “Shields”. Click on “Edit”. Go down to “Email Attachments Shields”. Click on “Email Attachments”. Remove the check mark from “Email Attachment”. Your email should work now. This is what I had to do to get my email to work.

I experience the same with Windows Live Mail. I can’t get my emails. How can I solve this? I have added wlmail.exe as an trustet app, but still no go.

I do not run Spy Sweeper.

Birger :slight_smile:

Hi, I had the same problem with sending SMTP mail…after upgrading to comodo v3.

I use Thunderbird, do not use Spysweeper…only after disabling Comodo v3 could I send mail again.

There is clearly a bug somewhere in there…disappointing really, when the new version overwrites the old…which was working just fine!

Sorry but it clearely is not caused by SpySweeper i have SS running for years now and had no such problems with Comodo 2.4 firewall or what ever program. As i said everything is working just fine but smtp (no matter what mail program is used) port 25 is somehow blocked. According to the e-mail settings it should work but it’s not.

There must be somekind of bug causing the problem, cant find anything in the log files that tells it has blocked anything. I gues i just have to wait untill the next version :frowning:

Maybe I should not have said the Spy Sweeper was the problem. I did not had any problems running the previous versions of Comodo and Spy Sweeper. But after installing V3, my email would not send or receive emails. Only after unchecking the “Email Attachment Shield” in Spy Sweeper, did my email start working properly.

Hi Zocor, I too use Mailwasher and Outlook 2003 and experienced the same problem. I don’t want to get into a long reply just yet, but I may have solved the problem. Right click the Comodo icon in the sys tray and look at the “defense and Security level”. If it’s on disabled or train in safe mode, change it to Clean pc mode. If you can send an e-mail and the firewall learns Outlook and you get one pop up, and the e-mail goes out, then we may have it fixed. So far it worked for me. One way or the other post back and I’ll give you the long story.

My email (Outlook 2002) and Spy Sweeper worked fine with version 2.4. Two days ago I installed and and the only problem I am experiencing is email. If I close Spy Sweeper then Outlook sends and receives without issues from my current dozen accounts. When Spy Sweeper is running then all accounts fail. I haven’t turned off the Email Shield, as suggested earlier, but will Have to do so if there are no other suggestions.

Are you using gmail or encrypted email through your ISP? Comodo left port 995 off the port list that supports their email client rules, so won’t work if you try to use that predefined policy. If you are using gmail and Thunderbird, also need to add port 587 for smtp. FTP also usually won’t work if you use their predefined policy.

Well there’s a new wrinkle. In my uneducated opinion, I would re-install v3, and disable SS before you re-install.

Hi and tnx for your reply twl845

Firts of all, i have Mailwasher Pro 6.0 and Outlook 2007 (V13.0) running but i don’t think the mailer version has anything to do with it. Outlook express (latest) is having the same problem.

The defence and sucurity level is (was) set to clean pc mode but dit not help.

For the remarks by ron302:

  1. SpySweeper was turned off (not running) during installation of CPF 3, and
  2. Turning off the “Email Attachment Shield” in SS, dit not do the trick for me sorry.

Anyone else have any suggestion?

The real problem is that in CPF 3 everything is set properly, but still the smtp (outgoing mail) does not work although port 25 is wide open and no other ports are used for smtp here. I had to uninstall CPF to get email to work properly, this way it renders CPF 3 worthless.

What is your smtp server-not gmail, right? Does your firewall log give an indication of what is being blocked? Attempt to send a message, and look for blocks to ports 53 , 587, 465, as well as 25. Are you using the Comodo predefined policy for email client? If so, erase the entry in the Network Security Policy and try just hitting “allow” when you get the firewall popups, instead of “treat as an email client”. Also, going to “options” in Outlook Express and selecting logging there might give some useful information. Don’t know whether Outlook does the same logging.

I got the fix. Ports 995 and 587 are missing. Add them and be sure to re-boot. Your mail will then work.

I really think a lot of you folks make things more complicated than they really are. Logically, if your computer was purring along just fine prior to upgrading to Comodo v3 and then it stopped accessing the web after installation…the culprit is Comodo v3 and some “mysterious” setting within it’s architechture, not a conflict with all these 3rd party applications.

I have found that with Comodo Firewall v2.4 that after intial installation, none of my programs would complete their access to the web. I had to tell Comodo to “Allow Fragmented IP Datagrams”. Everything worked after that. Where I live at, my DSL is on a “Reach” and I experience a high number of fragmented packets.

When I upgraded to Comodo Firewall v3, I experienced a similar Non-Responsive effect. Version 3, by default, allowed fragmented datagrams. So there was something else blocking my way. This is the setting I had to change to make it work. At the top of Comodo’s Display page there are 4 menu options: Summary, Firewall, Defense+, Miscellaneous. Choose “Firewall”. Under “Firewall Tasks” choose “Advanced”. Out of the four options available, choose “Attack Detection Settings”.
Under this menu you will find 2 tabbed headings. Choose “Miscellaneous.” Un-Check “Do Protocol Analysis”.
I have not had a problem with any of my programs accessing the web after unchecking this option.
I have found that if I leave the default settings Comodo sets at installation, nothing will work. You have to find the proper options that will work for you. The ones I have listed here today have worked for me.

If you also get msgs stating about your trusted programs not being proper 32 bit applications, You may find that you will have set “Defense+” to the “disabled mode” and just run the firewall only until fixes are made.
The way there is: DEFENSE+> ADVANCED> DEFENSE+ SETTINGS> GENERAL SETTINGS> Slide the control bar to “Disable” and restart your computer.