After I log off - other users sitill get a message stated that I am using GUI

After I log off - other users get a message that I am still using the GUI and that they have to wait.

For some reason there is still a cpf.exe process running under my user credentials. When an administrator tries to kill that process they get “Permission denied”

Any ideas?


– jculkincys


I have a similar issue. I’ve noticed two things…

  1. If user 1 & 2 accounts are both logged in on my pc, and I’m currently logged in as user-1 (i.e. this is the active account).

If I log out user-2 via task-manager / users, the log-out process does not terminate cpf.exe (user-2). In addition this process can not be terminated via task manager from the user-1 account. Then when I try to shut down my pc I get a warning that another user is logged in - when in fact they are not! It is the user-2 cpf.exe process that seems to be causing this alert.

  1. When user 1 & 2 are logged in, and I go in as the user-2, and log out whilst in the user-2 account, then go back into the user-1 account, cpf.exe (user-2) has gone

So, it seems to be dependent on how the user accounts are terminated.

I’ve not got any HIPS app running during this.


Looks like we have the same problem

Have you tried anything like a custom log out script?

I will bounce a few ideas around and then hopefully get back with something useful

Any wierd entries in the event log?

I’ve not noticed anything weird in logs. The issue isn’t really a problem for me, as I normally only have one account active on my PC. And when there are two, I just log user-2 out “normally” rather than via task manager. Just thought I’d let you know that you are not alone! :■■■■

What do you mean by log out “normally”?

I didn’t understand that in your first post.


by “normally” I mean from within the user-2 account, i.e click start & log-off. The problem occurs only when i’m in user-1 account and log user-2 off via task manager.

Hmm I get the problem when I log off normally (using the logoff button)

How do you log off via the task manager in Windows 2000 server? - I can’t find a way…

I don’t know if this is related or now but I tried stoping the Comodo service and it would not let me - “Permission Denied” - but I am logged in as an admin. This might be because the service is running as the Local System Account and I am a Domain admin??

Sorry, I’m on XP - and am not familiar with Windows2000. In XP there is a tab called “users” where you can log off other accounts.

The permission to terminate might be denied because CFP protects itself? To avoid malware terminating the firewall? Donno? !

If I remember correctly, to log off another user in W2K, you’ll have to go into Administrative Services, and from their I start getting fuzzy… It’s been a while… I think the icon is in the bottom row, maybe 2nd to last (lol, at least on the computer I was on…) Might be under Terminal Services that it would show the active users.

You are correct, Roy. It’s not quite so easy to make CFP quit its job…


Thanks for the post

I tried what you suggested but I am still unable to kill that user’s process (even after they logoff - it is still running)

This stinks - it makes it so unuseable if only the first user who uses the GUI can use it for the whole session - the only thing that releases it is a reboot.


As a question, do you use Fast User Switching, or do you have that disabled?


As I recall, logging someone off thru AdminServices in W2K is a two-step process. When you right-click the logged-on user entry, you get some options. I forget what they are, but there’s one way that looks right (and involves only one step) but if taken, it leaves the account actively running. The other way is a two-step process, logs them off and stops the actively-running account. We had this issue at an office I worked at before, because users weren’t logging off the server correctly, and with a remote user on, we’d reach the limit; then I’d have to go in and manually disconnect everybody (and they weren’t even on).


I have fast user switching enabled


Is it feasible with your situation to go back to the classic logon/logoff window (like W2K, etc) instead of XP’s FUS, to see if the same situation occurs there? Obviously it’s happening on jculkincys’s W2K system, but it’s always helpful to gather as many details as possible.


I’ll give it a go… & report back later…

Interestingly, if I log off user-2 from taskmanager in user-1’s account, I’m left with a user-2 cpf.exe

And then!

if I go back to the log-on screen, log in again as user-2, I get 2 instances of cpf.exe (user-2) and one of user-1. :THNK !!!


Right then!

I turned off fast user switching and logged in as user 1, logged out user 1, logged in user-2. At this point only one cpf.exe running.

The I logged off user-2 and when back in as user-1. Again only one cpf.exe running.

So… it looks like for me the issue only occurs in the fast user switching environment.


Okay then. And that’s with Win XP… is that Pro or Home?

Either way, it still is basically operating like W2K (from user perspective, not necessarily OS perspective) at that point. I wonder why it doesn’t work on the W2K system…?


Now then… (:WIN)… it is…Home Sp2

Not sure if this can work on xp but its what i do on my win2k. Before logging off, you need to manually shut down CPF. This is likely due to its anti-termination mechanism to prevent it being shut down by malware as shown in tests. Perhaps the way windows shutdown applications was used by certain malware too.

Even if I did not shutdown CPF before switching user, I was still able to use the gui on second user. I’m not exactly sure what CPF meant with its msg of first user still using gui.

Little Mac

Thanks for the tip - I will try to poke around and see if that helps

Also - just to confirm - I am experiencing this problem when connected direclty to the console and when connected via Remote Desktop.

A slight work around that I am using now is not having that Comodo Firewall gui automatically launched in the background when someone logs in. Correct me if I am wrong but I believe that the firewall is still protecting the computer. I REALLY like to get away from this workaround though.

Yes, the FW will still be running. You can verify this by going to Start/Run, type in “devmgmt.msc” to open Device Manager. Go to View/Show Hidden Devices. Then scroll down to the NonPlug N Play Drivers; look for Comodo Application Engine, Comodo Network Engine (if there’s no red “x” or yellow “!” everything is good to go).

However, without the GUI running, there is a chance (I’m not sure, you’d have to check) that all monitors are turned off and/or that everything is locked down. I’ve tried this before a while back (just to see what would happen), and it seemed like it didn’t function properly (don’t remember exactly what the symptoms were).

I agree, any “workaround” is not the optimal, for sure.

Have you tried EHL’s suggestion of exiting the firewall before logging off the user?