After Firewall Re-Install, It Ignores Blocked/Allowed Apps From Old Config

I wanted to update to the latest version of the free firewall using an offline installer, but the only offline installer is for a more complete CIS package. So I used a custom install to exclude everything but the firewall. But it installed more than I asked for, so I uninstalled that and installed the online free firewall only (without Dragon, etc).

Naturally, the fresh firewall config was very small and didn’t include almost 1K of items such as Blocked or Allowed applications, Port set customizations, etc, etc. But I expected a nearly empty fresh config after the installation, so I had exported various full config files prior to un-installation and planned to import them to return to my previous settings. Also, the original UI showed about 16 blocked applications, which is exactly what I wanted and needed.

But here’s the problem: I imported the old, large config files, but when I checked to see if those same 16 blocked applications showed up in the UI, they did NOT! The list was empty, which is entirely unacceptable.

So I tried copying all the XML entries describing all my blocked and allowed applications and so forth into the Fresh config (while leaving the rest of the file intact) and tried importing that, but I saw the same thing. In both cases, I used a tool to confirm there were no syntax or other XML errors in the config files, and they imported correctly without errors.

SO: How can I get the most recent firewall release to accept and acknowledge the cnfig items I need?


Hi Huzer,

Thanks for reporting. We’ll check this and get back to you.