After Comodo Uninstall can't reinstall Comodo or other app

Wondering if someone can help with this. I run an old Dell laptop, Win XP SP2, pretty current on patches, AVG Free AV, and until recently the Comodo free firewall. It updated itself a few days ago and everything seemed fine until I tried to run an mpg video and Comodo, in learning mode after the update, asked how to treat the app. I accidentally chose “isolated application” (which I have never seen before as a choice) meaning to reach trusted app. The mpg failed to run, and when I tried to run the video progam (vlc.exe), or irfanview or Win Media player, I kept getting the following error: You do not have appropriate permissions to run this application. I tried opening Comodo to see what was going on but could not open the menu. I rebooted. On reboot, XP came up but all the apps that run at startup were prevented from running by Comodo. I booted again, this time under safe mode and uninstalled Comodo. I rebooted in normal mode and went back to the Comodo site. I downloaded version 3.x of the firewall. When I tried to run the firewall install program I got an error - unable to continue. Now this occurs when I try to install anything - I tried to install zone alarm as a test. Same error. Re-Installing msi windows installer, ditto. I went through ccleaner and ran its registry clean function after uninstalling comodo any keys related to comodo. Same error persists!

Anyone know a way out?

Read through THIS
Ragwings .bat file is excellant and will hopefully sort your problems out.

Matty is a comprehensive guide, including a removal script, for removing CFP3. The program you isolated was probably explorer.exe, which acts as the launcher for other applications.

Thanks, All. The batch file did the trick. I missed some steps in the clean up process. Thanks for the help. :Beer