After Activating HIPS, cmdagent.exe Permanently Loads CPU To 30-40% [M1039]

A. ISSUE
[ol]- Summary - After turning on HIPS, cmdagent.exe permanently loads all CPU cores on 30-40%, permanently uses HDD.

  • Can U reproduce the problem & if so how reliably?:
    Every time I turn on HIPS cmdagent.exe permanently loads all CPU cores on 30-40%, when turn off - load goes down to 1-5% (idle)
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Install CIS (Don’t import an old configuration or create any HIPS Rules)
    2:Open main window
    3:Go to Tasks → Advanced tasks → Open Advanced settings → Security settings → Defence+ → HIPS → HIPS settings
    4:Enable HIPS
    5:After turning on HIPS, cmdagent.exe permanently loads all CPU cores on 30-40%. When turned off the CPU load goes down to 1-5%
  • If not obvious, what U expected to happen:
    The CPU Usage should not be near that high.
  • If a software compatibility problem have U tried the conflict FAQ?:
    NA
  • Any software except CIS/OS involved? If so - name, & exact version:
    None
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    A KillSwitch Process List is attached to this post.
    [/ol]

B. YOUR SETUP
[ol]- Exact CIS version & configuration:
Comodo Internet Security Premium 7.0.317799.4142

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Default settings
  • Have U made any other changes to the default config? (egs here.):
    I turned on HIPS
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    No
  • Have U imported a config from a previous version of CIS:
    No
  • OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7, SP1, x64, UAC - default, account type - administrator
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=None b=None
    [/ol]

[attachment deleted by admin]

Thank you for reporting this issue. Please create a diagnostics report and attach it to your first post. If you are not sure how to do that please feel free to ask.

Also, can you please also note what the CPU usage was when only the Behavioral Blocker and AV were enabled?

Thanks.

Hey Mad_cat

I had the same issue and spent the last couple of hours trying to fix it. The issue I had only occured when HIPS was enabled, the symtomps were high CPU-spikes (can be seen in Resource monitor) when this happend the computer lagged and my sound-card made a buzzing sound.

My solution was:

  1. remove CIS in windows 7 add or remove programs
  2. Download the comodo removal tools and save them to your hard drive
  3. Reboot your PC in Safe Mode
  4. Run both of the removal tools (there is a post in the forum with a link to both tools)
  5. Reboot into normal windows mode
  6. Reinstal CIS6
  7. Reboot
  8. configure as you like
  9. Reboot
  10. run tests

madcat, as suggested by freddy P., please do try reinstalling CIS by following the advice I give on this page. Let me know if the issue continues even after reinstalling by following those methods.

Thanks.

PM reminder sent.

I had one more problem with CIS 7.
Sometimes, after login into the OS with administrator rights, system hanged up.
Log:

  • System
    • Provider
      [ Name] Application Error
    • EventID 1000
      [ Qualifiers] 0
      Level 2
      Task 100
      Keywords 0x80000000000000
    • TimeCreated
      [ SystemTime] 2014-06-28T19:06:51.000000000Z
      EventRecordID 51497
      Channel Application
      Computer PC
      Security
  • EventData
    cmdagent.exe
    7.0.55655.4142
    534eeb61
    cmdurlflt.dll
    7.0.53315.4132
    5331cecc
    c0000417
    00000000002112a8
    138
    01cf92a7740b3ae2
    D:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe
    D:\Program Files\COMODO\COMODO Internet Security\cmdurlflt.dll
    5c2ed4ce-fef7-11e3-b0e3-6c626db3c486

So, after reinstalling, problem from topic - not solved, problem with hang up - solved.

I’m happy to hear that the problem with the hang-up seems solved. Just to be entirely clear, did you also run the removal programs from Safe Mode?

As for the CPU issues, please open KillSwitch. Then go to the KillSwitch menu and choose to Save Current View. Then please attach that file to your first post.

Let me know if you have any questions.

Thank you.

Have you been able to create the Process List by using KillSwitch and choosing “Save Current View”?

PM reminder sent.

  1. I have removed CIS in Windows 7 “Add or Remove programs”
  2. Reboot PC in Safe Mode
  3. Run both of the removal tools
  4. Reboot into normal Windows mode
  5. Reinstal CIS 7
  6. Reboot

Problem from topic - not solved.
By the way, problem with with hang up - not solved either.

Thank you. I just want to make sure of one thing before I forward this to the devs. After reinstalling CIS did you import an old configuration?
If not did you create any HIPS rules before the CPU raised up?

Thanks.

No, I didn’t import the configuration.
No, I didn’t create rules.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I have been informed that this issue you are experiencing with the occasional hang-ups is likely the same as an issue already entered into the tracker. To test this, please turn off URL filtering and reboot. Then let me know if the issue does not come back. If it doesn’t than it is the same issue as that already reported.

Also, it has been requested that I ask for a copy of your Defense+ logs showing a period where the high CPU usage is noticeable. Could you please supply me with that so I can forward it to them.

Let me know if you have any questions.

Thank you.

Hi mad_cat,

Devs have marked this issue as “Fixed” in version <8.0.0.4314>. Please verify.

Thanks.

The devs have marked this as fixed. I will therefore move this to Resolved.

If this is still happening on your computer please respond and let me know.

Thank you.