Adobe Photoshop CS3 - Photoshop.exe Suddenly Never Allowable

Since the last recent updates, I cannot do anything to make CIS allow Photoshop CS3 to open without popups. I use this program extensively to open photos, so it’s a HUGE problem. I’ve added the program to the Defense/Trusted programs list (including all subfolders). It’s now showing in the sandbox files.

It is not ‘remembering’ the action even though the box has been checked a zillion times.

“Photoshop.exe could not be recognized - not digitally signed”

It worked like a charm until last week’s updates!

Please help - I can’t deal with this 100 times a day!

Thank you in advance from Catherine.

Can you please post a screenshot of Defense+ events log.

Dennis

Thank you, Dennis - Here it is.

[attachment deleted by admin]

Can you please now post a screenshot of Explorer.exe like I have posted.

It appears explorer is blocking some Photoshop files.

Dennis

[attachment deleted by admin]

Dennis, I am trying to find that tab option in CIS.

Oops sorry forgot the important part.

Defence+ \ Computer Security Policy

Dennis

Edit Is Explorer.exe set as a Trusted Application?

I finally found those tab options by selecting ‘add’ and then browsing for photoshop to see if that would do anything; I did not complete the task because I saw the tabs you wrote of - so I’ll wait for your response.

I guess there is an expectation that clicking the ‘always trust’ box should make that happen, but its ineffective.

I appreciate it!

[attachment deleted by admin]

Please try and set Photoshop as a Trusted Application.

You will have to click on Use a Predefined policy the change it to Tusted Application

Dennis

Blast! I did that and there’s no improvement. Same popup! In the Defense + Rules tab, I added the program from the ‘running processes’ - than did predefined, trusted as you directed.

*I need to go out for awhile, so if you reply, please do not take the time lapse as disinterest. I am keenly trying to get this resolved after hassling with it for over a week and am grateful for your help.

Please try Windows System Application instead of Trusted Application.

Dennis

I did so, and hit ‘apply’. Still blocked as ‘unidentified publisher’ by Comodo.

I went back to double check and make sure I did it correctly.

Last resort do not like to suggest this, as this gives the program more rights than it should really need.

Change to Installer or Updater

Dennis

OK, I did that - still blocked. Closed out and opened up the ‘defense+rules’ tab again to check, and photoshop is not on the list (perhaps because installer or updater / does not show?). I reselected it from running processes, predefined + installer, apply, then tried again, still blocked. x’d out of the CIS screen, reopened, no photoshop program is on the list.

Popups still keep coming. Can’t imagine why so hard to correct! PS, each time, I am checking the ‘always trust’ box, too.

Will ask for further help new one for me deleting application rules.

Dennis

Thank you - I will anxiously stay tuned.

*May be important to note - this ‘only’ became a problem after last week’s CIS updates!

Always opened smoothly before, no hassles.

Let’s try another angle.

Please try all solutions provided by App. is not working correctly, but does not seem to be s/boxed. What to do? [v5] and let us know if any of them worked for you or not.

Thank you for the suggestion - I will do that and get back to the forum tomorrow.

I really appreciate your kind help. Have a lovely evening.

Just to clarify:

The log entry says ‘Create process, block file’

This suggests that what you are getting is a UA alert for Photoshop.exe. Is that right?

In which case making it an installer/updater in D+ rules and rebooting should work. If it doesn’t likely you have a conflicting rule.

This is one of the solutions on the list that Eric referred to, so its a good idea to work your way through it.

If none of these work maybe an uninstall/install would be best. Tends to make CIS work generally better anyway.

Best wishes

Mouse

Mouse - I have not rebooted, just hit ‘apply’ between changes. I just read the instruction from Dennis’s link, and they specify to reboot.

Yes, I get an Unlimited Access user alert with the option to check the ‘always trust, submit, restore point’ boxes or sandbox them. Have to choose ‘before’ it will open the photo.

(I didn’t think about uninstalling and reinstalling the program.)

*I wonder what changed, with the updates of last week? Everything was fine until then.

I will change it to an installer in rules and reboot?

Hey - I just discovered that the photoshop program keeps disappearing from the defense+ rules list after changing it to Windows System App OR Trusted. Seems odd. In other words, when I add it to the list, and x out of that screen and go back in, photoshop does not stay on the list once I’ve closed that page; it disappears.

That should be a clue! I’m flummoxed at this point. I was in the middle of a huge photo project and have about 200 photos open, so it will be a real chore to lose all that - but will reboot and check back.

Thanks!

Sorry UA = unlimited access. That sounds like the one you are getting.

If so making it an installer updater should work. If it doesn’t and particularly if ‘D+ rules’ are disappearing, I’d uninstall and re-install using the process here.

Best wishes

Mouse