Adobe Acrobat Shuts down after 10 seconds, no errors (Firefox or IE) -Solved

I was just experiencing a problem with Acrobat Reader (ver 8, but I don’t think it matters.) I had just installed Comodo firewall and was being harassed by all the normal prompts to allow or block different apps and services and started clicking allow or block. I have installed plenty of firewalls before and knew most of the apps (services and/or processes) to allow. Soon after this setup I was browsing the web and notice that a program FNPLicensingServices.exe was trying to access my computer. I didn’t think I clicked on anything related to a Macrovision product since this is the folder the app is located in. (C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingServices.exe) So, I blocked it. I didn’t notice any ill effects except in the following days when I clicked on any link to a PDF file it would open and display the PDF for about 10 seconds and then close and go to a completely blank page (closing the Acrobat tool bar and navigation pane.) It didn’t matter if I was in Internet Explorer or Firefox. The long story shortened is that Adobe Acrobat Reader (I have Acrobat 8 Standard installed, but I don’t think it matters) use FNPLicensingServices.exe to check it license folder for a license. Since I block the app from accessing my computer files/folders this would close down Acrobat with no errors or messages.

The solution is to make sure the service is started. Start > Run > services.msc and look for the FLEXnet License service is running and then open Comodo and click on Defense+ and then Advanced in the left pane. Then click on Computer Security Policy and then look under Application Names and look for the FNPLicensingServices.exe. Click on edit and then change the radio button to Use a Predefined Policy and change it to a Trusted App. I tried changing multiple combinations under Custom Policy but could not find the right access to make it work. I always trying to find the least amount of access for any app as possible, but was unable to find the combination. Hope this helps someone.

Additional information is available from Adobe.

Thanks for your help. I spent two days talking to the Indians and they never could figure it out. I sent them copies of fiiles and reinstalled three times. The last person I talked to started to take me the through the entire process a thrid time so I just hung up.

Only one alterration I had to make in your instructions. In addition to making changes to the FNPLicensingservices.exe I also had to do the same thing to anything referencing Acrobat. Finally it worked.

Thanks Again,
Bill Scott :slight_smile:

TechMan -

I can’t thank you enough for your post. I have spent 4 hours on the phone with a couple of very nice Indian guys (they really were nice) and finally goggled the right words to read your post. Many thanks. :slight_smile:

Just wanted to add my thanks. You nailed the problem and the solution.