Add COM class under COM group does not work[M508][V6]

Add COM class under COM group does not work.

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes, always
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: Advanced Settings → Security Settings → Defense+ → HIPS → Protected Objects → COM Interfaces → Groups, right click on any item under a group, add → COM Class, the add window does not show up.
  • If not obvious, what U expected to happen: The COM add window should show up.
  • If a software compatibility problem have U tried the conflict FAQ?: NO conflict.
  • Any software except CIS/OS involved? If so - name, & exact version: NO
  • Any other information, eg your guess at the cause, how U tried to fix it etc: The items in groups of Protected Files, Registry Keys does not have this issue; right click on any name of COM group also does not have this issue.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware): Attached

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: CIS 6.2.282872.2847, Proactive configuration

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: AV Stateful, HIPS Enable Safe Mode, BB Paritially limited, Firewall Safe Mode
  • Have U made any other changes to the default config? (egs here.): NO
  • Have U updated (without uninstall) from a CIS 5?: NO
    [li]if so, have U tried a a clean reinstall - if not please do?: NO
    [/li]- Have U imported a config from a previous version of CIS: NO
    [li]if so, have U tried a standard config - if not please do: NO
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 8 32-bit, UAC enable, Administrator, NO V.Machine.
  • Other security/s’box software a) currently installed b) installed since OS: NO

[attachment deleted by admin]

I can confirm this on Windows 7 x64.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

NOT fixed in 6.2.285401.2860.

Thanks for checking this. I’ve updated the tracker.

This bug has been fixed in 6.3.294583.2937.

Thanks, COMODO.

Thank you for checking.

In that case I will move this report to Resolved and update the tracker.