Adaware + Comodo issue?

I had a problem with adaware not updating so I did i manually, today I re tried the update function and Comodo said it was safe so I permitted it and I got the updates yet last time I tried it Comodo did not prompt me to allow it and the update failed, what could have changed that made Comodo prompt me?

ps This happened with Svchost.exe yet when I permitted that it did not appear in application monitor is this a glitch???

a small unrelated question I tried installing a squared and a alert came up with parent: explorer application: userinit.exe is this normal


I believe the updater had a bug in Ad-Aware previously because I was having issues with it in the past (even with Comodo disabled), so hopefully they’ve fixed it (don’t use it anymore). If you are worried that Comodo is blocking Ad-Aware because of incorrect rules, go to the application monitor and delete all the Ad-Aware entries this will cause Comodo to popup the alerts again for Ad-Aware and rewrite the rules.

Next, I believe this is normal, also here is some info on userinit.exe

userinit.exe is a key process in the Windows operating system. On boot-up it manages the different start up sequences needed, such as establishing network connection and starting up the Windows shell. This program is important for the stable and secure running of your computer

Also I don’t believe svchost.exe is supposed to be listed in the application monitor, but I could be wrong.