Activation server is down ?


Since yesterday I cannot contact activation page at!PlaceOrder to activate free products.

Updates download works fine.

Is this Comodo problems width servers or at my side - width ISP ???

seems good from here.

pls check again


I’m having same issue here. Just tried it about 15 mins. ago (1:45 AM, Pacific Coast Time). Sent email to Tech Support as I wonder if this has some bearing on my ongoing Activation issue.


Strange - we’ll look into it.

For the last week, I’ve been trying to get an activation code for my CPF re-install. Every time that I click the Submit button after entering my name and email address, I’m taken to the “This page cannot be displayed” page. I just tried it 5 minutes ago and had the same result. I even tried Allowing All traffic… same result.

What’s going on with that server?


Same problem…need to activate the firewall on the other machine and have not been able to
for the past few days. I am attempting to activate via the firewall itself.