Activation Error [resolved]

When I try to activate my license so that Comodo will not expire, I get the following error:
An error has occurred. Error -2146697211: Unknown error, please contact support.

I noticed that I get the same error even if I type in an incorrect activation code.

Any one have any suggestions of how to fix this?

Thanks, -A

Been having this problem since day one, even with a new key issued by Comodo been unable to register

Having the same problem for all versions and betas. Nothing helped!

Wonder why Comodo keeps an uncanny silence on this very annoying matter, otherwise its an excellent and stable firewall so far.

Arup/hpj: Apologies. The latest versions of the beta should not exhibit this behaviour - if you are still having these issues, pls read through some of the following FAQ topics which should be able to help you.

Install and un-install issues and resolutions,302.0.html,873.0.html,1184.0/topicseen.html

Pls note that we had an earlier issue with Installshield that caused several installation issues, and may have also influenced activation in unknown intermittent ways. As a result, we dumped Installshield about 6 weeks ago and used our own installer in the 2.3 betas.

Also, I’ve also done a quick search of the forums and came up with the following additional threads that may be of assistance to you in which we’ve discussed some activation issues and how to resolve them.,153.0.html,424.0.html

If you continue to have problems, pls submit a ticket to our support team at and, with your help, we’ll do our best to resolve your issue.

No go Paulo, same dreaded error, giving up at this point, also no response yet from tech support.

Arup: Sorry to hear that. If your error is the same as the one reported below, it has to do with CPF not being able to connect to the web, and appears to be a very intermittent error. Can you share your CPF logs with us, pls, so that we can see what’s going on?

Thanks for the response Paulo. I will look into what you are saying and let you know if it helps. Ironically, I work for a software development company and we to abandoned InstallShield a while back. We went with NSIS instead. InstallShield is one of the worst products that I ever worked with, I can’t understand why it continues to be so popular.

Well, I reinstalled the firewall using the beta installer. Evey thing seems to be working fine now and I activated the license with no problem. Thanks for your help Paulo.

Amadeus: Good news - glad to hear that your issue is resolved, and that others have shared in our pain with Installshield.