Acquiring network address / Renew IP address / Comodo firewall problem? - Help!

I have tried everything to resolve my problem, and after spending hours trying to fix the PC, I’m now at my wits end…

My laptop just can’t connect to my wireless router, yet my daughters is working fine. I can’t even open to access my Netgear router settings either.

When I hover my mouse over the Netgear icon, the message there is: 'Signal strength: Very good and ‘Acquiring network address’ - From there, I have right clicked and opened ‘Wireless network connection 2’ and then asked it to ‘repair’ - When I do this, Windows cannot ‘Renew my IP address’ and I’m sure this needs to be done first, before I can fix anything else.

An ‘Intel’ Troubleshooter message also appears, and the message states: Did not receive IP address - The wireless adapter failed to get a valid IP address.

I posted this message on another forum, and it was suggested that maybe the issues could be with my Comodo firewall blocking my ISP…

Have any of you been through the same thing, and can help me please? I need to sort this out as soon as possible. Apologies if this isn’t really the place to post my query, but I’m desperate, and really can’t afford another visit from the PC repair man :frowning: ( Oh, I’ve only just had the PC back from a reformatting, due to viral troubles - could this be the cause of my current woes? :cry: )

Many thanks

This should be fixable. Can you show me screenshot of your Firewall logs and Global Rules? They can be found under Firewall → Common Tasks → View Firewall Events and Firewall → Advanced → Network Security Policy → Global Rules.

How to post a screenshot?

When the window you want the screenshot is active push alt+print screen. The window is now copied to the clipboard. Paste the image in any image editing program, Paint,, the Gimp etc, and save the file as 32 bits png image.

At the forum push the reply button. Or when using the Quick reply type some text and push the preview button.

Underneath the text box click on Additional options. Push the Choose button and navigate to the file and select it. When you want to post more images click on the more attachments link.

When done typing push the Post or Preview button.

Hello Eric

I can’t post the screenshot thru Paint, as I can’t send it over to my daughters PC which I am using now.

I have compared her Comodo global rules and mine though, and they are very different.

My settings say:

Block ICMP Out from IP Any to IP Any Where ICMP Message Is PROTOCOL UNREACHABLE
Block ICMP In from IP Any to IP Any Where ICMP Message Is 17.0
Block ICMP In from IP Any to IP Any Where ICMP Message Is 15.0
Block ICMP In from IP Any to IP Any Where ICMP Message Is 13.0
Block ICMP In from IP Any to IP Any Where ICMP Message Is ECHO REQUEST

Her settings say:

Block IMCP In From IP Any To IP Any Where ICMP Message Is ECHO REQUEST

Please can you help? I was up until 2am this morning trying different remedies, and nothing works :frowning:

Many thanks

Hi Clare,

I had a simialar problem several days ago. I went through the typical trouble shooting (disable and reenabling the card, powering the router and modem up and down, etc.) and coudn’t for the life of me figure it out. What worked (at least to this point) was disabling the firewall, turning off the router and modem. I then restarted the modem and router and then rebotted the computer. At that point the machine was able to pick up an IP address and I went in and reenabled the f/w.

I was desperate to get up and running and have not explored a more long lasting fix, but it at least got my computer reconnnected.


Do you have a USB stick so you can transfer the screenshots to your daughter’s computer? It could be of help if I could get the firewall logs.

Can you try the following for now? Go to Firewall → Advanced → Network Security Policy → Application Rules → make sure System and svchost.exe are not blocked. In case they are blocked use the Edit button to change their policies to Outgoing only for the moment.

Keep us posted.

Well, I was getting so frustrated, so I called the PC repair guy, and told him that it could be a Comodo set up issue.
He told me to remove Comodo, and then see if I could get online - at least that way, I would know where the issues lie.

I went ahead and uninstalled it, and guess what…I am now back online on MY pc.

I am relieved to say the least, as now I know that I haven’t got yet another horrendous problem to solve :slight_smile:

Now, I want to reinstall Comodo, but need to set it up correctly (I still don’t know why my settings changed without me going in there, but hey ho!)
Could you kind folks direct me to a page that helps you with the set up of Comodo please? I’ll scream if I do it wrongly on my own :cry:

Thanks again!

Here are a few things to keep an eye on after installing CIS

One of the first things you will probably see is an alert for a new found network. It will show and IP address in the message. When the IP address is in the 192.168.x.y and 10.x.y.x range you can accept it and give it a name (say something like My Home network). That will be all for now.

When you get alerts for System or svchost.exe give them the policy Outgoing Only. That should keep you on the safe side of things for now.

Can you tell us on what type of connection you are? ADSL, Cable…?

When things go haywire again I absolutely need the Firewall logs as described in the above to take a look under the hood.

Keep us posted. :-TU