Acess Denied IP=, Port=route(520)


First time here. Excelents firewall and forum.
Could you help me to solve a problem? Well, I am not sure if it’s a problem .

My log:

   Description: Inbound Policy Violation (Access Denied, IP =, Port = route(520))
   Protocol:      UDP Incoming
   Reason:       Network Control Rule ID = 5

What’s going on? Should I add a rule or this is normal?

Thank you in advance.

Tiga Jr.

Welcome to the forum.
Do you use a router?
You should make a trusted network in that case.
Go to security/tasks and click on “define a new and trusted network”.

Port 520 is used for RIP (Routing Information Protocol)
If you have more than one router that needs to “speak” to each other, you need to allow this. I you only have one router, you can turn RIP off in your router settings.

Hi AOwL,

Thank you very much for your quick answer.
Yes, I have a router. Only one. It is an old NEC, but a very good router. I can’t turn the RIP off in my router settings. Is there another way to solve that?
I am moving to Comodo now. I was using another excellent firewall (Tiny Personal Firewall - TPF). Unfortunately, CA acquired TINY Software in 2005 and killed it.
The only things I miss in Comodo are Sandbox and HIPS. I am telling that, because in TPF I could create a rule to deal with that problem.

Thank you again for your help.

Tiga Jr.

You can make a rule for that in network monitor.
You can allow or deny it, depending on if it causes any problems.
It’s just inside your network, so you don’t need to be concerned.
Make a rule with log enabled, so you can see how often, and in what occasions it’s showing up in the logs. If you don’t want to see it in the log, just uncheck the log box.

Go to Network monitor (security/network monitor).
Right click on your block rule and add/add before.
Do these settings.

Action : Allow & log (you can probably block it too)
Protocol : UDP
Direction : In
Source IP :
Destination IP :
Source Port : 520
Destination Port : A single port : 520

If anyone else knows more about RIP, feel free to jump in…