Accidently blocked port 139

I have been using Comodo Firewall for a little while now, but I have accidently blocked port 139 (I thnink) and now have a lot of issues accessing my network shares.
All I am looking for is where do I alter this setting which was set when a pop dialog warning was displayed and was only meant to block it once but ticked the box “always remeber”.
Under which category, menu or setting would I find this?

firewall rules are created under firewall tab → network security policy

I have looked in there but could not find an entry.
Would this be apparent in the list shown or do I have to edit each one and find the one with port 139 in it?
All I know is that I made a block with a dialog with port 139 shown.

can you post a screenshot of all your application rules