Access to DNS/RPC Client Service no longer monintored on Windows 10 [M1556]

A. THE BUG/ISSUE (Varies from issue to issue)
Only on Windows 10 x86 & x64 CIS does not detect application access to the Windows DNS/RPC Client Service a.k.a COM Interface \RPC Control\DNSResolver.
Can you reproduce the problem & if so how reliably?:
Yes very reliably
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Execute any application that performs DNS query’s using the Windows DNS/RPC Client Service. I used dnstester.exe from SSTS64 proactive security challenge test suite.
2:Either set HIPS to paranoid mode or safe mode with the application rating set to unrecognized.
3:Notice no alert for accessing the DNS/RPC Client Service.
One or two sentences explaining what actually happened:
Any unknown application can communicate over the network without an alert using the built in Windows DNS/RPC client service.
One or two sentences explaining what you expected to happen:
I expected CIS to display an alert when an unrecognized application attempts to access the DNS/RPC client service (COM interface \RPC Control\DNSResolver)
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
I used dnstester.exe from the software security testing suite 64 archive available here: password is ssts64
Any other information, eg your guess at the cause, how you tried to fix it etc:

Exact CIS version & configuration:
Version Proactive configuration
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS=Safe mode, Auto-Sandbox=Disabled, Firewall=Safe mode, AV=not installed
Have you made any other changes to the default config? (egs here.):
Disabled the auto-sandbox, added *\RPC Control\ntsvcs and *\RPC Control\DNSResolver to Protected COM Interfaces.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 x64, UAC=Disabled, Admin account, non-VM
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=N/A b=N/A

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Thanks again

Not fixed with version I want to make it clear that this bug only applies to windows 10 x64 with enhanced protected mode enabled or disabled, as windows 7 x64 CIS does generate an alert when an application accesses the DNS/RPC client service, whether the program is of unknown rating or trusted with defense+ set to paranoid mode.

I’ve updated tracker data.
Thank you.


Just I have retested again with the last CIS version and It is Not fixed with version yet.

I’ve updated tracker data.
Thank you.

Fixed in CIS 10 beta.