access to -- a microsoft download site

I’ve founded (or think I have) the instructions on Block/Allows Websites to Users of Your Computer, Network Security Firewall to allow the download of a Visual Studio 2017 RC programs but still get the Unsage website Blocked page.

Is there a more recent set of instructions to allow getting to so called bad website (that aren’t)?

disable the web-filter and try again but I had no problems downloading the visual studio rc setup with the web-filter enabled. Also try clearing your dns cache by running from the command prompt ipconfig /flushdns.

Did those things and didn’t help, I must be doing something wrong. Even completely turned off all security. The Comodo unsafe web site keeps coming up.

Is there a link somewhere on my machine that redirects it to the Comodo page.

Sounds like a dns filtering issue are you using comodo secure dns? Are you sure you disabled all of the security components of CIS by opening the advanced settings and unchecking each component then ok out the settings and then make sure you exit your web-browser then re-open your browser and try to visit the site again.

I believe I have see attached image. Thanks for your continued assistance.

Run CCleaner if you have it installed to clear out your internet cache as it maybe saving the cached request and do you know what DNS servers you use for your connection?

Have run ccleaner a number of time as this has been happening plus flushing the dns. The DNS servers are those of centurylink (qwest), IPv4 and

I have no other suggestions, and this is very odd, comodo shouldn’t be blocking any website when you disable the webfilter. I noticed you linked the webfilter rule creation for v7 of CIS though it is still the same for the latest 8.4 but are you using an older version or are you using the latest 8.4?

OK, I took the certain path forward and it did work. Uninstall CIS, install VS2017, reinstall CIS.