About Windows not recognising CPF

Hello all,

I downloaded and tried CPF and found it to be a powerful firewall, although I still need time to fine tune and get used to the new interface. :slight_smile:

I too had the problem of windows not recognising CPF in Windows Security Centre. I searched thro the forums and found this fix https://forums.comodo.com/index.php/topic,545.0.html but it did not help directly but from there i discovered the cause.

In the command prompt, commands like ipconfig, ping, tracert, etc cannot work unless the full path was typed in , eg, c:\windows\system32\ipconfig. It Seems like the path was not correct

On typing in path in the command prompt i got the following:

Computer A with CPF
PATH=%systemroot%\system32;%systemroot%;%systemroot%\System32\Wbem;C:\Program Files\QuickTime\QTSystem;C:\Program Files\Comodo\VEngine\

Computer B without CPF
PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files\Qu
ickTime\QTSystem;C:\Program Files\Comodo\VEngine\

Thus on computer A, i right click on my computer Icon on the desktop-> choose properties → advanced → environment variables → under system variables → path → i changed all %systemroot% to C:\windows and rebooted the machine.

After that, windows was able to detect and list the firewall in windows security centre. I tried with computer B as well and had the same problem and needed to change the settings before windows can detect the firewall.

Is this a bug? Hope that this bug can be fixed in future versions . :slight_smile:


Hi Cavey,

thank you very much for the feedback. We have fixed the bug and will issue a VE update soon.

Thanks for the cooperation,

Excellent post, Cavey! I will be trying this tonight.

In my case, the firewall reported by Windows Security Center is currently NAV 2006’s “worm control” firewall (yes, I am using Norton Antivirus 2006 on my machine). That has always bothered me, but I figured NAV was so intrusive that somehow it had taken control.

Hopefully, this may just fix that!

Thanks again for reporting the PATH correction.

Egemen, I am running CPF version There is no “C:\Program Files\Comodo\VEngine” folder on my machine (please see Cavey’s earlier post).

Here are the folders where CPF is installed:

C:\Program Files\Comodo\LaunchPad
C:\Program Files\Comodo\Personal Firewall

I tried putting the latter folder in the PATH statement to see if Windows’ Security Center would then recognize CPF in place of NAV 2006’s “worm control” firewall – but no luck.

Curiously, my original path statement did not contain a string referencing ANY Comodo product.

Is there a way to FORCE Windows to recognize CPF as the firewall?

Windows Security Centre recognises security components through WMI, not through the path variable. It may help, but it’s not the primary means that Windows uses to communicate and acknowledge these components.

EWen :slight_smile:

NAV does not take control but it seems while accessing windows security center interface, NAV is doing this first. Not a big issue. CPF is still active. So nothing to worry about.