A/V defs update failure with CIS v7

Its bad enough that v5.12 A/V defs don’t update - must update manually - but I discover that v7.x doesn’t either. I attempted multiple CIS v7.0.317799.4142 A/V defs updates. Appeared to complete w/out error, but version remained v24661 updated last 15 Mar 26.

In the …/scanners folder during update a b0024826.cav file w/ 39MB appeared before disappearing. Now I’m noticing during update it claims to be downloading files, but there’s no internet traffic evident. Subsequent update attempt showed same file w/ 16MB - spins its gears at 90% before completing successfully - the b0024826.cav file disappears - leaving only the b0024661.cav file. Presently the b0024826.cav file grows to only 636KB before updating successfully and leaving the b0024661.cav, rinse, lather, rinse and repeat.

Tried to download bases.cav.z from:


yields: v24467 15 Mar 7 !?!?!?!?

Tried to download bases.cav from:

claims Latest Database Version:

Release Date (all times GMT):
17-Apr-2016 08:58:23

Number of Definitions Added Today:
10925 !?!?!?!?!? Really? Just today? That seems excessive, but out of 42 MILLION its merely a fraction.

In any case, the size of both files, i.e., bases.cav or that in the .z file are the same. I installed the file manually in CIS v5.12 and About shows v24467. I tried to import that into CIS v7.x and error: invalid version number inside defs file.

That’s not a surprise; the downloaded file - allegedly v24826 but is actually 24467 - is 284,540KB, while v24661 a/o 15 Mar 26 is 282,836KB. That makes some sort of sense; the more A/V defs that get added to the defs file, the smaller it gets; the archived A/V defs 15 Jan 4 was even bigger than the currently offered v24467. Eventually the A/V defs file will be 0KB and protect against everything, and after that updating the A/V defs will increase the capacity of the hard disk and protect against threats not even dreamed up yet.

Right? Why am I not amused.

I added CIS v7 to the topic title to be more informative. Eric

A/V defs still don’t update. I managed to import the latest A/V defs complete, i.e., BASE_END_USER_v24840.cav w/out error. Then the update continues - downloading incrementals to 24912.cav - and completes successfully.

The final A/V defs version: v24840 after the 39MB v24912.cav file disappears.

I tried updating A/V Defs again after deleting all CAV files in I:\Documents and Settings\All Users.WINDOWS\Application Data\Comodo\Cis\wpTemp.

Goes thru aforementioned gyrations, leaving the final version v24840 after the 39MB v24912 disappears.

downloaded bases.cav - it is v24840 - with size of 286,915KB; it is the version currently installed; it being then current full A/V defs 16 Apr 19 and imported that date. I did not import this file again today.

I deleted all incremental files - in E:\Documents and Settings\All Users.WINDOWS\Application Data\Comodo\Cis\wpTemp - and then performed manual A/V update from CIS main GUI. CIS successfully downloaded 119 incremental A/V defs files - from v24841 to v24959 - totaling 241MB. CIS successfully applied / finalized them and successfully created a file b0024959.cav 0KB. Update completed successfully.

After the newly created v24959.cav file in the scanner folder successfully disappeared, the currently installed A/V defs successfully remains v24840.

I find it peculiar that the CIS A/V defs update is successfully failing, and moreover, that the A/V defs are growing at a rate of 241MB every three weeks. That’s a growth rate of 4.9GB / year.

I downloaded the full A/V defs. They are the same version as 19 Apr 16.

The A/V defs still don’t update.

16 May 23 I downloaded the v25090 defs file and was able to import it. No more recent full CIS A/V defs have been available. ALL subsequent - as were all previous - updates completed successfully.

The A/V defs version has reamed the same after each successful update.

Most recently - within the last 48 hours - I uninstalled CIS as nearest completely as I could. To do so I incorporated EVERY CIS uninstaller known to Mankind. After that I manually deleted the CIS folders that remained anywhere. Then I removed any vestige from the registry that related to CIS.

Then I reinstalled CIS v7.last.version from scratch and attempted to update A/V defs. First thing it did was download all X MB of v25090 and then all the incremental updates. This completed successfully. The final A/V defs version: 0

I did the foregoing - including delete the incremental download folder - about 20 times - and each time ti downloaded the FULL A/V defs (how much bandwidth do you think I wasted?). Anyways: I ran CIS v7 Dx and it came back total health. Suddenly the /Scanners folder visible in Explorer popped with a new file, i.e., b00025090.cav file AND the installed A/V defs was shown to be 25090.

In a nutshell: the total A/V defs servied up by Comodo install w/ out error. NONE of the incremental files install thereafter.

This remains to be a prollem.

on 16 Jul 25 I imported BASE_END_USER_v25390 from .Z file generated 16 Jul 6 and attempted to update A/V DB. The update failed successfully; the defs remained v25390. However, I noticed that E:\Documents and Settings\All Users.WINDOWS\Application Data\Comodo\Cis\wpTemp contained BASE_END_USER_v25399.cav 297,625KB. However, such file was not available for download at any site. I was able to import that file out of that folder successfully; the CIS A/V DB version active reflected v25399.

However, NONE of the incremental CAV files through v25525 would update. The system would create a b0025525.cav file that grew to 36MB - 41MB and then complete - update successfully - however, the A/V defs remained v25399 and the b0025525.cav would disappear.


609 views and not a single response.


My machine is either failing, I’ve been hacked or there’s a fundamental issue with CIS updates.

It seems to me that the very first thing I need to do to resolve this issue is create a clean install of OS + CIS v7.x on a clean HDD and observe the results.

I can only say what I did on my Vista desktop x32 (+ a Win 7 x64 laptop), upgraded from v5.12 to v6 then v7.

Please note you cannot upgrade from v7 to v8 the file list goes and no new entries.

Never had any problems with virus updates apart from when the actual servers where down.

I used to do a weekly update on the Vista comp. it was a bit slow at times downloading the updates, now I usually update every day please note these are all manual updates Vista comp. as rarely online once maybe twice a day.

The likely reason you have no replies is no one else has your actual problem.

Sorry this does not really help you.


Thanx for the response.

What’s really weird about this is that some time ago CIS v5.12 A/V updates broke on my PIII-1400S platformed Win2003 R2 system. BUT, if I boot into Win XP SP3 on the same machine, I could update CIS v7.x, and then ‘port’ the CAV file into the CIS v5.12 A/V DB supported by Win2003 R2 on a different drive and requires memory and mobo resources to transfer. Except - now - that is broken in WinXP as well.

I tried this again 16 Sep 3 in the WinXP platformed CIS v7.x and notice incremental files downloaded to wpTemp from v25583 to v25699. However, versions 25646,25645, 25641 are unusual; they’re all less than 12KB; two are less than 5KB, while the remainders are ~2070KB.

I’m skeptical this pertains to SSE+ CPU functionality; it worked in WinXP SP3 CIS v7.x until shortly before O/P date. Neither am I convinced this pertains to a memory issue; nothing has changed in that regard. Moreover, I experience on BSODS, and can download the compressed CIS A/V defs and extrace them with impunity. That has always been the canary in the coal mine WRT memory issues. Furthermore, I can run Prime95 with impunity for hours w/out error.

What would be nice would be a means / utility to integrate incremental A/V defs into the ‘main’ DB. That way I could ascertain if these ‘weird’ incrementals are the prollem chil’s.

EDIT FWIW: it never FAILS the update in WinXP SP3 platformed CIS v7.x - like it would with memory issues - but completes successfully, although the A/V defs version remains unchanged. Almost smells akin to root-kit, eh?

Windows 7 64-bit User - Brazil

No Automatic updates from 25726 database! I wonder why?

Mandhi, I am having the same problem. I am a Windows 7 Pro SP1 64-bit user and the last CAV update was 25726, a couple of days ago. I am in the USA. I believe the CAV update servers may not be updated, or down, or experiencing some other type problem.

My Windows 7-64 bit too! Thank you

I’m also using Win-7 x64.
My CIS version =
My AV signatures version = 25740.

They were updated a few hours ago.
But it was done while I run a Smart Scan of Comodo Cleaning Essentials (which updates the virus db before doing the scan, to be effective.)

Maybe you could try to do it that way and see if it makes any difference?
The latest sig db = 25741 (dated today)


I tried, but not worked! Thanks for trying to help!


Mandhi, have you tried to update with Comodo’s built-in VPN (TrustConnect) turned on ?
Problem might be locational?
(forgive me if that’s a stupid suggestion … because I’m not a computer ■■■■… the opposite in fact, heh… but I’m really sympathetic because I’m having my own problems)


Thanks for the new suggestion! I’ll wait normalize! I’m very upset! If we find a solution, we post here! OK? Hugs.


Settled here!
Campinas - Brazil
Thank you!

The problem is resolved here in Chicago as well. I succesfully updated CIS to CAV database version 25750. Whatever issues there were with COMODO’s CAV update servers have been corrected. Thanks!


Thank you so much!


Just ran Prime95 with the worst possible parameters, and 7-Zip blend @ 64MB dictionary size, passed the test w/ out breaking a sweat.

I just ran the 7-zip benchmark, and it passed w/ out break

I just tried to download the CIS A/V defs; it remains the same as 7 Aug 2016.