[a]"Thumbnails is Corrupt and Unreadable" [b] Also, how do I shut off Thumbnails

Hi there.

Q.1: Since yesterday, my DRAGON has started issuing alerts of a corrupt file. I’ve print-screened the alerts and placed them in a sharing folder at Mediafire so you can see them:

File sharing and storage made simple

  1. The alert demands to run Chkdsk. I did this yesterday, a couple of times. The alert keeps coming back anyway.

  2. Today, when the alerts began again, I ran the “repair” option on the Comodo software. No effect, the alerts began popping up again.

  3. I then, today, uninstalled and reinstalled Comodo. No luck, the alerts began again. The alert pops up continually, it’s driving me nuts.

  4. I cannot run Chkdsk every 5 minutes!

  5. Comodo Dragon Version (Stable/Beta) e.g. Dragon (Stable)

  6. Plugins/Themes installed in Comodo Dragon - NONE

  7. Windows version (w/ 32-bit) e.g: Windows SP 3.5 (32-bit)

  8. UAC status (diabled/enabled) if it applies to you [ for Vista/Windows 7 only! ] – don’t know what that means… sorry!

  9. System Drive where Windows is installed: “C” Drive

  10. Place (installation path) where Comodo Dragon is installed:

        C:\Program Files\COMODO\Dragon
  11. User privileges: it’s wide open, I’ve never blocked off access, I’m the only one using this laptop.

Q.1: I notice that the thumbnails alert is somehow connected to the PREVIEW page when I hit new tab, that comes up like Opera with thumbnail previews of sites recently visited. It so happens I don’t like this, I just want to go straight to my home page, google, so how can I TURN THIS THUMBAILS page OFF? Thanks.

Appreciate it.

P.S. Could you PLEASE adjust DRAGON so it doesn’t LIMIT the length of a FILE name when I am naming and saving a web page or other document? Thanks. This is really important, I’m saving case-law, and it has to be by complete name of each case.

Hi, P.S. It’s 15h31 13 Sept 2010 – the print-screens of the thumbnails bug are still uploading to the Mediafire sharing url in my first messsage… seems slow today, “low” on the free wireless at the library.

When running the chkdsk utility what does it tell in the result screen? Did it state it could fix it or not?

What happens when you uninstall CD and delete the offending folder and install CD again?

This has virus written all over it. Have you performed a virus scan lately along with a malware scan?

Hi, hccanada

It seems like some file in Dragon’s folder is corrupted . It could be some filesystem’s fault :frowning:
Anyway, try please one of these steps .
( Try 1st one first, if it doesn’t help, try second one, thanks )


  • Close Dragon .
  • delete Thumbnails file from C:\Documents and Settings\PUT_YOUR_USERNAME_HERE\Local Settings\Application Data\Comodo\Dragon\User Data\Default folder
  • Run Dragon

2: only if 1st one didn’t help . You need to rename User Data folder (C:\Documents and Settings\PUT_YOUR_USERNAME_HERE\Local Settings\Application Data\Comodo\Dragon\User Data )

  • Close Dragon
  • Rename “User Data” folder to any name you like
  • Run Dragon ( now Dragon will create “new” “User Data” folder). Run Dragon again to make sure it works ( it works, doesn’t it ? :wink: )
  • Close Dragon
    Now you’d like to export your bookmarks I think.
  • Open your renamed “User data” folder and copy “Bookmarks” file to your current “User Data” folder
  • Run Dragon ( now it shows all your bookmarks ) .

Hope it helps,


Hi. I was kind of worried someone might say that. On 21 August 2010, I brought my laptop to the guy who had sold me the new hard drive on May 1st 2010. He said there was a virus, and he charged me $40 to “clean” the system of viruses. However, when I got home & installed AVG, it found over 200 “threats” including several instances of something called SysAnti – which somebody online calls “drive killer”.

Well, if my technician removed the viruses, why was SysAnti still in here, and dozens of others! I ran AVG, which isolated some of the threats, but declared it couldn’t access the others. AVG then sealed off my hard drive and partition and my USB key as its way of “healing” the viruses!

I uninstalled AVG and installed Comodo. Comodo found the “malware” AVG had used to seal my drives, and unsealed them. Comodo then identified over 200 “threats” and resolved some of them. It took three tries at 3 hours a try, total 9 hours, and the laptop “shut off” in the midst of the second 2 of the 3 comodo scans, leaving the scan incomplete.

I then installed AVIRA which completed the scan and “successfully” isolated “all” threats.

However, as you can see, there’s this problem with my comodo browser… and the little yellow emergency triangle alerts that it keeps setting off, warning about corrupted thumbnails feature… looks just like the alerts that set off with fonts in Adobe 9 just before my system went haywire and I brought it to the tech.

I wonder if there’s a specific place to look in my syste, for this attack on the thumbs feature of Dragon? I did delete the offending file-folder… the odd thing is, when I uninstalled Dragon in order to re-instal it fresh, the uninstaller couldn’t “find” two folders of Dragon…

When I had my big system issue on 21 August, at some point, the icons on my windows desktop entirely disappeared… so I went into DOS to look for my files… which were THERE… but DOS commands attempting to copy them or move them resulted in a notice that the files “could not be found”… which is odd… because their names were all there, I could see them. So, now, again there’s this “can’t find” folders message with uninstalling Dragon, which kind of has me nervous that the system attack may be happening again…

Do you think I should try again with Comodo anti-virus? Or would the AVIRA have done the job?

Thanks a lot.

[ P.S. password-reset didn’t work, so I had to join up again to read my messages; this time I used the name watcher2.]

Hi, step 1 didn’t work, I got a can’t delete corrupted file message.

Step 2 seems to have worked, and Dragon is up and running again! And no corrupt file alerts!
And the bookmarks are back, except for the icons – which is easy enough, I’ll just do them again.

Thank you very much! I really prefer the Dragon, now. The design is much more logical and intuitive than Firefox, IE, and even Google Chrome… once you figure out it’s all in the mouse.

( I wonder though if the corrupt file is ultimately due to a virus, as suggested by someone further up this thread… the “diamond” shaped avatar. )

Meantime, Thank you!
: ) ;D

Hi, when I did that the other day, it was alright for a couple of hours, then it became corrupted again.

Val3entin (below) gave me a fix that worked, I had to use step 2. It worked to force Dragon to create a new “user data” folder. Then Dragon worked fine again for 2-3 hours, and unfortunately, when I used it to view YouTube, shortly into that, it was corrupted again – this time the flash file was corrupted. I’ve print-screened that, and also I’ve print-screened a login problem with this forum. Both are here in the sharing folder:

When I go to my email and click on the link to allow me to sign in with my new account and password, it says “an error has occurred” (I’m in firefox, now) – and “user does not exist”. However, when I inserted the login and password, I did get in. This contrasts with a similar error I got trying to re-set my password to my first account, HCCanada – the reset link produced a similar “error” and 'user does not exist", but it would not accept – or perhaps it wasn’t showing me the right window – my attempts to login with my account and a new password.

  • Do you think the Dragon issue is gonna turn out to be a virus?

Thanks for your time.