a question about My Network Zones

When i go under “Firewall” and “My Network Zones” I only see a loopback zone. In this normal? Do I need to add my network zone?

Hello Viper,

Yes this is normal, this is “internal” traffic between an application and the OS.

You can use a “network zone” if you apply it to a firewall policy, you could create a network zone that contains your local home network for example 10.1.1.0 / 255.255.255.0 and call that zone “Home Network”

Now you can use this object in the firewall policy as:

Allow, IP, In/Out, From, Src Zone = Home Network, Dst Zone = Home Network, IP Details Any.

That would allow your systems on your local network to access your pc and your pc can access all systems on the home network also.

This is what i have discovered regarding this issue. When i install comodo it does not recognize my network and therefore the only network in “My Network Zones” is the loop back. However, if (while in windows) I unplug my modem and plug it back in comodo now detects my network and adds it to “My Network Zones.” When this happens comodo blocks more, and my internet runs smoother.

Seems like it did not detect your network at first, can you tell me a bit more about your network connection.

Is the modem connected via USB ? What type is it ? is it using PPPoE perhaps ?

What’s the CIS version you are using ?

Hello.
I have the same problem. At start - only Loopback. Ant CIS does not recognize new network.
My connection to Inet through USB (mobile phone Nokia 6260).
Besides, I deliver IP dynamicaly.

OS: Win XP 32 bit SP2, CIS 3.8.477

My modem is a Motorola SB5101 and my internet provider is rogers. My modem is connected directly to my computer by a network cable. My NIC is a Marvell Yukon Gigabit Ethernet controller.

When comodo detects my network and adds it to “my network zones” comodo firewall blocks better and my internet works better and smoother.

Can you please check if you have alert for new networks enabled ?
Misc, Settings, General, Automatically detect new networks.

If so check you network zone again, and see if only loopback is there.

Now open a command-box and type

ipconfig /release
ipconfig /renew

The first command will release your ip address from your adapter, the second one will renew a DHCP request to the network adapter, if that completes CIS should detect your network, if it doesn’t please post a “bug” in the bug report section for CIS Firewall bugs.