A few small bugs

I start playing with the latest Bacupk and notice small bugs :

  1. Backup doesn’t honour folder for temporary file and create “zia01220” file in the destination folder.

  2. On Destination tab in Destination folder field I can’t write "C:". When "" is entered, the cursor skips to the beginning.

  3. I work under Polish version of XP. The “Aplication Data” folder calls here “Dane aplikacji”.
    Comodo creates two folders:

“C:\Documents and Settings\Grzegorz\Dane aplikacji\Comodo\BackUp\Data”

and

“C:\Documents and Settings\Grzegorz\Application Data\Comodo\Backup\Data”

The first is empty, the second has CmdBackUp.log file inside. I suggest to remove the latter and write log into the first.

  1. Maybe I missed something but Backup doesn’t preserve the state of the service. At the moment I want to run it manually and don’t know how to stop the service.

  2. On “Destination” tab “AddMacros” button is disabled. I don’t understand why it doesn’t work here ?

  3. In Select source folder in Include mask click … → checkbox don’t preserve the state - all are disabled although I’ve already declared the mask.

  4. In the registry Backup writes under HLM\Software “Comodo” and “ComodoGroup”. Could you please use only one branch ? There is also under HLM\Software\ComodoGroup\Comodo Backup\ two entries “Users” and “users”. An oversite ?

  1. If the name of a source folder has "" (backslash) at the end (for example c:\AAAA) and the destination is compressed, then extra folder WINDOWS is added between AAAA and subfolders.
  1. BackUp ignores (does not copy) folders and files with [ and ] characters in the name (like AAA [xxx]) when the destination is compressed zip file. Show Files works OK.
  1. When the source is C:\AAAAA\BBBBB, BackUp set BBBBB as relative folder. I suggest to set AAAAA\BBBBB as a default because BackUp doesn’t preserve the directory structure. It happens only when the destination is not compressed.

  2. As other thread has already stated, incremental backup does not work with compressed destination. BackUp copies all files again.

  3. I notice strange behaviour. First I set compressed file name as #Date_Time##test.zip and Full backup. Next I set Incremental backup. On Compress tab the file name changes to test.zip and Add macros buton is disabled. So I close with OK button and next time Add macros is enabled. WAD ? For me looks like a bug.

  1. Backup does not comply with Macro options during backup made in schedule mode. For example the file from manual backup calls 20061013_2316_kopia.zip. The same backup definition via scheduler gives 2006yy10mm13dd_23hh15mm0sskopia.zip