A few Problems (Changed title)

Hi, on the build posted yesterday I’m getting a CSC.ini file missing when switching between the cleaner options:

Windows 7 RTM Build 7600.16385

[attachment deleted by admin]


In order to reproduce the bug, we need the following details:
- is the UAC activated?
- do you have a internet connection on Windows 7 machine?
- is it a x32 or a x64 system?

Hi Razvan.

I’ve tried with the UAC both off and in the default setting, It makes no difference. There is an active Internet connection for this PC and it’s currently using x86 build I haven’t had time to install my x64 build yet.

Edit: I’ve also tried it on an older build of Windows 7, 7100 RC build, and it behaves the same way.


Right click on the executable and choose “Run as administrator.”. Please tell us if this makes a difference.

Right click on the executable and chose "Run as administrator.". Please tell us if this makes a difference.

Hi, I tried that before and it failed to make a difference. I also tried the repair option but it failed to find the file on my system, see screen shot. I only have the executable, is the msi packaged within?

I decided to reinstall. I removed the D+ and firewall rules and removed the application. On first run got the second screen shot but this time it updated, however, the missing CSC.ini file is still present when the application is launched for the first time and before the update can take place.

After restarting again, it seems to have settled down.

[attachment deleted by admin]

Strange, if I disable the UAC CSC won’t update. If I enable the UAC and try to run the application as a normal user I get the runtime error above. If I run it as Administrator it seems ok,

The UAC for Windows 7 has a lot of changes that are not well documented . This is why this problems appear.
We’ll fix this problem until the final release next week.

Thanks for support!

A couple more things :slight_smile:

It appears CSC still doesn’t recognise Mozilla Applications such as firefox or seamonkey, regardless if they are installed into default locations either on XP or Windows 7. I also don’t see privacy cleaning options for Macromedia Flash or Shockwave, Will this change in the final release?

Last thing for now, when selecting the Privacy Cleaning Option, the initial scan is quite quick, however, if I select to scan manually, it doesn’t stop, well I left it for 10 minutes and it hadn’t changed. This too is on XP and Windows 7.

I also noticed on Windows 7 a slight corruption of the interface which wasn’t evident on XP, see attached.

Thanks for your help :slight_smile:

[attachment deleted by admin]


We tried to reproduce the XP bug you mentioned regarding CPC scan but everything was fine…scanning went well, no freezing progress or such.

Please tell us what type of security software are you using on Windows XP. Any additional information on this issue is welcomed.

Thank you for your support.

Hi Adrian, on both the XP box and the Windows 7 box I only have CIS resident. This is not just XP it’s Windows 7 too and it’s repeatable every time. The initial scan when selecting Privacy Cleaning is ok, but selecting the scan button bottom right, on XP and Windows 7.

it works fine on Registry scan, but on Privacy it just stops and does not change even after 10 to 12 minutes had passed. It is however, possible to cancel the scan, at which point CSC reverts to the initial scan window.

Apologies, I just wondered if wiping free space is working? Wiping a single file or a few files seems to work ok, but when I chose to wipe the free space on the drive, very little seemed to change.

To observe the effectiveness of ‘wiper’ I did a before and after of deleted files, using a couple of free undelete utilities. I then compared the result with Eraser Erase unused space. In the case of CSC I used 'US Government Standard Fill - 1 iteration and with Eraser I used 1 pass with Pseudo random data.

With wiper there were no differences between the before and after, however, with Eraser everything was overwritten successfully.

Perhaps I’m comparing apples with oranges but they both say that wipe/erase free space?


What exactly do you mean by differences between before and after ? Wiper zero-fills the free space, leaving nothing behind ( no deleted data ). We tested and this function reached its purpose. Did you find any data left in the free space with an undelete utility ?

Thank you for your support.

Hi Adrian, here are some screen shots of what I’m trying to explain:

The first is a screen shot of some of the deleted files on the C: drive before running CSC wipe free space
The second is a screen shot after running CSC wipe free space
The third is after using Erase free space from Eraser

As you can see there are clearly differences between the two.

As I said in my earlier post, I am, perhaps comparing like with unlike, yet both state they wipe free space. So, my question is why is there a this difference?

[attachment deleted by admin]