8012 - HIPS events causing Windows to freeze after going from 1909 to 21H2

Build 8012

After patching Windows 10 from 1909 to 21H2 my current HIPS settings:

  • Paranoid
  • Display all alerts, verbose.

Results in several applications causing the entire computer to freeze for several minutes until finally an error message appears and I can click it. Normally this takes so long that I’ll just hard-reset the computer.
I used to have this issue before as well, but then it occured with applications (games) being blocked just as they took control of the screen. My solution then was to make a game profile that was already configured for various “game” requirements.

Same results past/present however, with keyboard/mouse movement frozen, yet the power button would magically work (quick-press should result in a safe shutdown procedure)… just that it took forever.

Now it seems to be caused by when an application tries to access system memory, but I could be mistaken as I’m not 100% sure if comodo manages to log the event that occurs when the alert appears, but if I run the same application with everything blocked (and it runs) I can see in the log file what is being attempted that I have not allowed.

Is there a way to make comodo not freeze the computer when this and other events occurs? Would the adaptive mode work… it seems like a weird feature so I’ve never used it.

As it is now I need to put everything on ‘block’ by default, and then add profiles for everything I run. Where in the past I’d have several applications configured in HIPS but I’d also run some applications with pre-configured profiles and not save them to HIPS configuration, such as Installers.

In addition, as someone else also posted, I’d like to be able to NOT have events that I have explicitly blocked in configuration be posted to the HIPS log, or at least an option to disable logging these events (like you can with Firewall rules).

Would it be possible to have a setting that can automatically block a selection of events, applied to all, instead of just “block all”,“allow all” as this would prevent the freezing of the computer whilst still allow me to get notifications on new apps and what they are trying to do (and then allow me to apply a profile to them, or allow/block each action individually).

Hi k1k2k3,

Sorry for the inconvenience, we’ll reach you through PM to get the required information.