[] Now Force-fed Yahoo?!?

I just updated to the newest version ( and despite clicking decline my default search was changed to Yahoo. Any attempts to change it to Google and delete Yahoo as a search option are reverted when I restart the browser.

I uninstalled and did a fresh install of and now Yahoo has become my Start page and Search and now BOTH are returning on restart if I change them!!

What the hell is going on and how do I get rid of this unwanted ■■■■!?!?

Do you have Comodo Internet Security installed? In case you have could you see if Show alerts in case any other software attempts to modify current settings of installed browsers is enabled or disabled?

Yes I do and Yes it’s enabled. I get the message every time CCleaner runs.

The problem is the message isn’t going to show when it’s your own software forcing this.

It’s only CID affected. CD (which CIS installed) is fine.
I didn’t have this issue until right after the version of CID was installed.
I’ve installed regular Firefox 59.0.2 (with CID still installed) and have no issues.

The issue is clearly CID.

I tried to reproduce on CID but it didn’t reproduce. Can you think of an extensions that you have in CID that might interfere?

As mentioned, I uninstalled after the update and did a fresh install of, so I have no extensions.

Comodo is the only products on my computer consistently trying to put PUPs on it.

Here’s some fun stuff from google image search. The top one is even the one I clicked “Decline” on.
Sadly the forums aren’t setup to allow any [spoiler] or [hide] tags, so apologies to anyone viewing on a mobile device.


Can you check with Task Manager if Mudra_offering_screen.exe is running? Did you see the Yahoo offer after installing? See attached image.

I just mentioned I had clicked decline on that same image in my previous post (also mentioned it in OP).

You may not be able to reproduce the issue, but I can.
I just uninstalled again. Downloaded and installed 57.0.4
Successfully removed Yahoo as start and search.
Clicked Help → About IceDragon to trigger the update to
Once updated tried to remove Yahoo again and can’t

Working on recording it.

Got it recorded. It’s split into two videos because the “offer” window didn’t want to show right away. Only showed up as soon as I stopped recording. Also, to start from scratch I had to uninstall again, so that’s two successful attempts at reproducing the problem.

Video 1 / Video 2

…and here’s a video of it happening after a clean install of

Hi Duir, thank you for the feedback!

I have investigated this issue and after your videos manages to reproduce the issue.

For me seems to only reset the homepage/search engine if I put about:blank as my home page or picking the “Show a blank page” as startup.

Can you check if putting a proper page as homepage (not a page that starts with about:) still resets the homepage/search engine for you?

I will pass this issue to the development team to fix in the next release.

Thank you very much,

Made no difference. [Video]

Hi, Duir! Thank you for the feedback.

We found the root cause of this bug, you will need to select the default search engine even if it is the only one left. (see attached screenshot)

We will address this bug in the next version of IceDragon.

Thank you very much,

Thank you. Can confirm this is working and once I select Google (the only remaining and already shown option) my homepage and search engine are not forced back to Yahoo.