403 and 550 errors - help a newbie out please!

Am a recent convert from Zonealarm - using Comodo 3.5 and Avast on XP home SP2 - all set up and updated as advised by forums/sites.
Two issues possibly coincided with this change (?) - have already tried everything suggested by Comodo desktopsupport disabling firewall/defense etc. without success - and other ideas gleaned from the internet.
My ISP is Virginmedia (ntlworld) and when uploading/editing the webspace provided by them I am now getting a 550 permission denied error.
Also a 403 Forbidden Unauthorized IP address error greets me when trying to access a private torrent site - xtremewrestlingtorrents
The ISP insist neither problem is caused by them - though as I maintain several other websites hosted elsewhere without any problem I suspect the ftp error may be a specific issue that they are in denial of.
However am mystified by the other error as I know I have not been banned by the torrent site (I can access it but obviously not download from it via a proxy.)
The two issues are completely unique and specific - I use ftp to update the other websites and I have no problem accessing other private torrent sites (including two others that are “associated” with the one that is blocked - xwt-classics and all4nothin)
My browser of choice is Firefox (with a variety of addons - Adblock, Noscript etc.) - but IE8, Opera and Googlechrome all produce the same result. Ftp is by Fireftp and Filezilla. I also use utorrent - but as I cannot access the site and it works properly on other sites it’s unlikely to be a factor?
Was wondering thus if anyone here might have any thoughts or suggestions? I’d rather stick with Comodo/Avast rather than retreating back into the expensive clutches of the Zonealarm Security Suite if at all possible!

Here are the custom rules for FTP and uTorrent. I’d try removing the affected programs from D+ and the Firewall, running them again and re-setting the rules, trusted or training mode in D+ and the custom rules for Firewall.

Hopefully they’ll help



Thanks Hikertrack - no joy unfortunately - have reset, reinstalled and tried every possible - and impossible - configuration but to no effect - three ftp programs, three browsers and 2 torrents clients all work perfectly - except with the specific offending sites.
Guess I’ll admit defeat for now - or wait for problems - and/or sites to miraculously cure themselves :THNK.

It is likely that this issue is unrelated to CIS as well especially if disabling CIS firewall and Defense+ was not able to solve those Code 550 and 403.

I guess completely uninstalling CIS and test those sites again could be able to clear any remaining doubts.