Thanks for a great product. I am having trouble updating the virus database. I uninstalled the app and then reinstalled and updated it about a week ago. It only completed the update once and thereafter kept indicating that it is unable to update beyond 30%. It is the second time that this problem rears its head.

Any tips?

All the best.


I had no problems with updates until 19 December I go on leave to come bac ktoday and no matter what I try i can not get past 30% update then it gives me a connection error

Any Clues ?

Try replacing Bases.cav. You will find it in the C:\Program Files\COMODO\COMODO Internet Security\scanners directory.

  1. Boot to safemode
  2. Go to C:\Program Files\COMODO\COMODO Internet Security\scanners
  3. Delete or rename bases.cav
  4. Go to C:\Program Files\COMODO\COMODO Internet Security\repair
  5. Copy bases.cav from C:\Program Files\COMODO\COMODO Internet Security\repair to C:\Program Files\COMODO\COMODO Internet Security\scanners
  6. Reboot
  7. Open CIS and update virus defs

Hope this helps.
Let us know


i also am having he same issue here are my specs

dell xps 630
vista 32 bit home premium
4 gigs ram ddr2
dial up connection

steps i taken so far
uninstalled older version of CIS since it wouldnt update. i cleaned the reg of all remaning keys.
i have downloaded the latest posted version CIS_Setup_3.5.57173.439_XP_Vista_x32
installs just fine no errors update freezes at 30% now since i run dialup i let it run it continually pulls bandwidth but it dosent do anything. it eventually gives an error about network connection or just stops with no error and the last date updated is still when i installed it. and i am currently stuck at database file 668 or zero if i try to update and it fails. i also checked the reg files for the path of the def and it is correct its not trying to use the old one i saw that in another post here.

and i tried the steps outlined above with no joy. now like others i have not had any issues until sometime in december. i love this program i dont want to have to give it up for a bloated crapware others offer. but having old sigs isnt protecting me.

[attachment deleted by admin]

Thanks xiuhcoatl I tried the solution you advised and it seems to have resolved my problem



In my dial-up connection, take aprox 2 hour to update the file bases.cav, has 25Mb.!!

freeze too on 30%, but update at end.

25MB!!! I just checked my installation on my home computer and the bases file is 25MB. I don’t usually notice how long my home computer takes to update the antivirus, but the file size is 25MB.

I too am on dial up and probably will be for ever as I doubt I’ll see highspeed where I live in my life time. I too am having trouble with the download stopping at 30%

Is this downloading 25MB thing every time the anti virus has to update going to be permanent from Comodo? If so, maybe it’s time rethink using this product.

Please help Comodo… Not all the world has hi speed.

Just installed .439 and have the stuck at 30% problem.

Finally downloaded on the 2nd try. The next update seems to be much smaller. Part of the problem is that there is no indication of when the downloading portion ends and the local update begins and is in progress. Since the install seems to take an unusually long time it is highly desirable that this be shown as two distinct events with their own progress bar in my opinion.

I’ve the same problem.

I’ve tried uninstalled CIS and Installed CSC to clean all registries and reinstalled CIS. Result = Wasted 1 hour.

Changed the files as suggested on above post…time wasting.

Conclusion, a bug that happen for more than 6 months (as seen on other similar update problem) without a proper solution…

FREE means BAD. Sorry but I’ve tried, luckily didn’t go for pro. Waste time waste money.

George Lew