3 of my Comodo monitors are frozen in the off position.....

My “Application Monitor”,“Component Monotor”, and Application Behaviour Analysis", are all
in the off position, and all the clicking in the world doesn’t unfreeze them. Maybe I will just
have to uninstall and reinstall the program? Or…is there a tech answer?
Any help would be appreciated.

Hi gwrfargo, welcome to the forums.

Sorry, you’re having trouble… this sort of error indicates that CFPs drivers have failed to load. Has CFP ever worked on your system or is the first time you have installed it?

It is possible that CFP is conflicting with another firewall (not XPs firewall) or security product. Do you have anything like this currently installed?

Also please confirm which version of CFP you’re using & what your Operating System is. Thanks.

When this has happened to me, not very often but I do a restart of the pc and all is well. Just a quick suggestion until you and Kail find what may be causing it.


Same symptom on my machine. Neither reboot nor re-install helps. Tried registry cleaning, disabling/uninstalling of other security software before re-installing. All internet connectivity is usually shut off, though for a few minutes today it was available, then lost.

One of the warning pop-ups said “Application monitor has incompatible version; re-intstalling might help”–or words to that effect.

Windows 2000 SP 4. System Information showed Inspect.sys and another driver (CmdAgent.sys?) started and an executable (CmdAgent.exe?) loaded.

Have read great things about this firewall from apparently knowledgeable people, so would love to see how it works. Any help greatly appreciated

Yeah, me too. I installed it today and I can’t seem to get the Application and Component monitors up. My application behavior analysis is also down. However, my network monitor seems to be turned on? I’m also running on win2k too. Anyone have any hints as to what could be wrong?

Version works much better for me. Only installed it an hour ago, so can’t be too sure, but maybe you’ll find it worth a try, TaN09. Hope so anyway. Good Luck!

Hi, please, if having problems, as kail stated, we need to know what version you are using as each can be a different cause.
Also, please re-read Kail’s post above and if possible , answer if you have previously installed CPF, previous versions, other security software, etc…

Other security softwares with advanced monitoring may be blocking CPF, also, if need be , install CPF first then other securities.



I’m running v2.4.17.183 on win2k SP4. I think I might have some leftovers from other firewalls I’ve used in the past? I tried cleaning them out manually and used Tuneup Utilities 2006 and CCleaner as well-to no avail.


If you’ve ever used ZoneAlarm and haven’t searched their forum for instructions on thorough uninstallation, you might wish to begin with http://forum.zonelabs.org/zonelabs/board/message?board.id=inst&message.id=63136 and the link provided there. Even following these instructions leaves a registry key,


so you may have more searching to do.

Don’t know if this will help, but maybe it’s a start.

Yeah I’ve previously had ZA as a firewall, I think you’re right. I have cleaned up most of it, maybe there’s some left, thanks. Do Kerio, Jetico, and Sygate have unclean uninstalls too? Maybe I didn’t clean up all of that either, registry residue.

Kerio like CFP leaves legacy keys that can only be deleted by granting yourself full control permissions just by right-clicking.

Could you expand on how and where I can do that :Beer

  1. Type regedit in the Start menu > Run…
  2. Click on Edit menu > Find… (or Ctrl + F) and search for the specific key words like “cpf”, “comodo”, “kerio”, “kpf”, whatever they may be.
  3. Once you’ve reached a key that won’t let you delete, then set the appropriate permission like the attached pics indicate.
  4. Now you can delete the registry keys (not values).

[attachment deleted by admin]

Thanks man. If I remove all registry residue from other firewalls, should CPF work now? And should I uninstall CPF and then remove it completely from registry and all it’s files and then install? Or is it okay if I reinstall over it? Sorry if im asking too many questions

Don’t worry, I’m sure this forum has an abundance of storage for questions :D.

I think the easiest step is to try deleting the residual keys from former software first. If CFP is still giving you errors, then uninstall it and do the same with deleting CFP legacy keys and reinstall. This recently worked for one forum member. Be aware that a clean reinstall will wipe away any saved rules and settings. There’s a script created by a couple of moderators to help you save them if you want.

As always, back up your registry - you don’t want to make an error! Either that, or be extra careful.

Ohgod, didn’t back it up. Ah. It’s fine, I can undo changes with this rescuecenter wizard thing. Does everything have legacy keys ???

Not everything. Only certain software/drivers.

Well, my monitors still don’t work :(. Oh well, at least it cleaned up some junk prior to Comodo, thanks for the advice though. Any more suggestions?

There have been a lot recent reports in regards to this problem. If you exit and restart CFP, does it make a difference? I only got this idea from this thread. You can also try this one. I don’t know what else to suggest…

Thanks for all your help, my support ticket didn’t even get answered =[. I’ll try these out. Oh wait, Outpost has a registry key protect, maybe that’s the problem? Does Jetico and Kerio have registry key protect too? Jetico could never load anyways, maybe I’m doomed not to use comodo lol