3.10.102194.530 major problem: Kills DOS programs!

OK, I’ve done a bit more sleuthing and I think I’ve discovered what the problem is when I tried to run the program under Vista/Win7.
I should explain that I run a multiboot system, so I can run XP, Vista or Win7.
The DOS program I was trying to run was on a shared data drive accessible from any of the OS’s.
It seems that because I had tried to run the program first from XP, the Comodo bug which is preventing it from running has also changed some of the NTFS permissions of the files in the folder. This is what was preventing it from running under Vista/Win7 - not the Comodo bug as such.
If I right-click on the Command Prompt and say ‘Run as Administrator’, it runs fine.
Also, by copying the folder from the D:\ dive to the C:\ drive in Vista/Win7, it effectively reset the permissions allowing it to run from a normal command prompt.
So it seems the bug is only affecting XP, but it does some other nasties to the file permissions which can cause grief.
Hope this helps.

I’m familiar with DOS - but I’m not really sure about ‘normal’ DOS programs.

  • I can’t run command.com (which is a very special DOS program, and I’m not sure, if it’s still 16bit or 32bit in WinXP),
  • I can’t run ClamAV, which runs in the command line without any GUI, but the download page states it’s a Win32 version, so it’s probably not a ‘normal’ DOS program.
  • I can execute some simple programs compiled with Digital Mars C, C++ Compiler. It creates also command line applications for Win32 by default, but they’re running just fine.

I doubt that I’m having any old real DOS programs, which would run on pure DOS.

Ok, try a few simple things. open command prompt and type Edit, open a file and make changes, save the file.

If, as the previous posted suggests, it’s an NTFS issue, see what happens when you try to open an application, maybe something like explorer…

Tried typing edit in a command widow (XP SP3) – got this result:

The system cannot execute the specified program.

Same for me “edit.com” can’t be executed, but “tree.com” runs just fine for example.

The same problem with the same Comodo version here, with the same symptoms, on several Windows XP SP3 systems. Typical standard command-line programs that does not work include: command.com, edit.com, debug.exe, exe2bin.exe, and mem.exe.

More serious is, that for some strange reason the bug also seems to affect my 32-bit accounting program, but why is unclear. But since it executes and connects itself to a number of other programs at program startup, any of those may be the problem.

Inactivating guard32.dll by renaming as suggested it temporarily solves the problem - at least I now can run all of these programs.

How exactly do you go about allowing .com files? That may be the problem. I can run any .exe from the command prompt but anything with the .com extension will not run.

This only affected me as I run with parental control on. Without it you should get a pop-up asking if you want to allow the .COM file to run (but I did not check this worked).

Go to Defence+, Advanced and “Computer security policy” and select explorer.exe. In “Access rights” find “run an executable” and select modify. In the allowed applications add c:\windows\system32*.com or where ever the .com files are located.

I had the same problem with all my DOS programs running under XP. It did go away when I uninstalled 3.10.102194.530.

Thank heavens I encountered this forum on Google search after only wasting a couple hours!

Incidentally, I think that Quattro Pro for Windows version 5.0 is the best spreadsheet ever written!

I can’t edit the policy for explorer.exe because it’s a predefined Windows system application and I cannot modify the run an executable section. actually I can’t modify anything. I created a custom profile for it allowing all executables and it still won’t run .com files. I cannot type anything in to the rules but can only choose file groups or browse for particular files.

Maybe CIS is causing XP to think anything with the .com extension is a web address and that’s why it says “Attempt to access invalid address”

To those who want to downgrade to 3.9: this version is still available at http://eu5.download.comodo.com/cis/download/setups/CIS_Setup_3.9.95478.509_XP_Vista_x32.exe and http://eu5.download.comodo.com/cis/download/setups/CIS_Setup_3.9.95478.509_XP_Vista_x64.exe . Good luck!

In case you missed it:

Re: COMODO Internet Security 3.10.102194.530 Bug Reports

Windows XP Pro. Firefox.

I too was alarmed to find the DOS program that I’ve used for years to store data could not be started after upgrading to the latest Comodo (3.10…)
I was finally pointed to this thread and after uninstalling 3.10 and reverting to Comodo 3.9 I am now able to use the DOS program as normal.
(Prior to reverting to 3.9 I found I could access the program using the utility Dosbox)

I want to thank you guys for the forum. I have XP but am still running Windows Cardfile from Windows 3.1 because I like it. I had just done a defrag of my computer so when I couldn’t open Cardfile and got the message we all got, but could open Office 2007 programs and browsers, I figured the defrag had done something wrong. I hadn’t paid attention to the fact that I had clicked the “upgrade” for Comodo firewall as well!

I tried Googling the error message (Attempt to Access Invalid Address) but the first several pages were to other forums going back to 2003 and 2004. I never thought of Comodo as a possible cause. After Safe mode offered no relief I read more Google pages and happened upon this one. Was I relieved! I uninstalled 3.10 and reinstalled 3.9.

I’ll wait patiently for the Comodo fix (and resist upgrading again, as I got two invites already). I just want to thank all those who bother to post their problems and all those who offer suggestions and solutions.

This problem was fixed with the latest update. Please update CIS.



Hi Everyone

Please read this: https://forums.comodo.com/firewall_bugs/please_dont_post_cis_310_bugs_he_read_this_first-t42120.0.html


Edit by EricJH: Sorry Josh for barging in on your post here.

Update #531 does seem to fix this problem. Thanx, guys! :slight_smile: