3.10.102194.530 major problem: Kills DOS programs!

After installing CIS 3.10.102194.530 I noticed that DOS programs would fail with error “Attempt to access nvalid address.” I didn’t check ALL my dos programs, but start | run | command.com fails.

Restore to previous checkpoint (on 7/2) and problem goes away.
reinstall CIS update, no problem until system reboot, which causes error to come back.

Windows XP Home SP 3 fully patched and updated.

I have exactly the same problem but with XP-PRO. SP3

Googling this error message reveals lots of people with this problem over the last few years.
Most of them claimed it was caused by viruses or trojans and some claimed to have fixed it by removing the offending virus but but there doesn’t seem to be a common cause.

It would appear that some program is illegally reserving the memory intended for DOS applications.

I have scanned my machine for viruses and found nothing.

The only change made to my machine since the last time my DOS programs worked is the Comodo update.

It looks like a bug although probably it doesn’t affect many people since DOS programs are rare now.

Any suggestions welcome.

Is there a more direct method of bringing a suspected bug to Comodo’s attention?


Glad that I am not the only one that found this. I had to revert to 3.9.
See https://forums.comodo.com/feedbackcommentsannouncementsnews_cis/comodo_internet_security_310102194530_bug_reports-t42039.0.html;msg305328#msg305328


It does the same thing for me. Typing in cmd in the run box works fine but command or command.com does not.

You can add me to the list.

XP Pro SP3_x86.
Core 2 Duo E6600 2.40 Ghz
Corsair DDR2-800 2048 MB
IE 8 & FF 3.0.11
CIS 3.9.95478.509
SpySweeper Antivirus
A2 (on demand scan)

Misery does love company! ;D

Yeah, but those folks using a DOS program are probably not doing it frivolously – i.e. they need that function.

Oh, I know, I’m one of them.
I have all my finances on Lotus 1-2-3 for DOS spreadsheets, state of the art or what?

works for me, I tried cmd, command, command.com no problems here. Vista SP2

Maybe this is an XP issue? Seems to function here, Vista x64 SP2.

So maybe we have found something that is only an XP issue for a change.

Me, too. (Best spreadsheet ever made.) Even my 1-2-3 v.4.01 for Windows won’t run. It’s still 16 bit, among a few other DOS and 16 bit programs I depend on. How do I undo the update?

This happened to me, too. Very frightening as I have lots of DOS utilities, some of my own, in use! So I sadly downgraded to 3.9.

Perhaps, it may be of help that the culprit is guard32.dll. It is registered as one of the DLL’s to be loaded along with all programs. If you rename, delete or unregister it then the problem of being unable to run DOS programs will go away. But, most probably, the protection will, too. (Dunno what exactly this DLL is as it has no meaningful description.)

Anyway, keep up the good work!

Very good, so a change to the guard32.dll should fix the problem. From what I find it is a necessary part of the firewall.

I have this problem on Vista SP1 32bit.

My problem is caused by explorer only being allowed to run an .exe file and not a .com file. If I allow .com files as well in computer security policy command.com runs OK.

I have tried a DOS program which I regularly use on XP SP3, Vista32 SP2 and Win7_32_RC_7200.
I have discovered an even more bizarre twist.
On XP, the program refuses to run at all.
On Vista and Win7, the program seems to run fine if I copy the complete DOS program folder onto the C:\ drive.
If I try to run it from another drive (D:\ drive as I would normally do), then the program starts up but then fails when it tries to access a particular data file in the folder.
So it seems the problem occurs on all 3 platforms to different degrees.

Any chance you can identify a ‘normal’ DOS program that doesn’t work, I’d like to test it here

sta64, very good sleuthing. I looked at everything but Comodo. I had a clone still at 3.9.95478.509 and Autoruns shows nothing under the AppInit tab. With 3.10.102194.530 the only item under that tab is guard32, which I unchecked and everything’s back to normal except Comodo. Is there a way to go back to that version without uninstalling/reinstalling? And if there isn’t, is that version archived somewhere on the site?

What is a ‘normal’ DOS program?
For example I’m using the command line scanner ClamAV which doesn’t work anymore, since I’ve updated to CIS 3.10.x (neither the scanner clamscan.exe nor the updater freshclam.exe). But it’s probably not a normal DOS program, since it comes with DLL files. It’s a command line application.
(I’m also on Win XP, SP3)

What is a 'normal' DOS program?

Sorry, if you’re not familiar with DOS, it’s been around for 25 years or so now. By normal I mean a DOS command. Open a command prompt and type help…

If it’s a problem with something that ‘normally’ runs under windows but has command line interpretors, it’s something different.