3.0.17.304-Importing old format settings corrupts new format settings

I first tried an update, and selected yes on the message that said the format had changed. Seemed to be OK with default settings. Importing old settings cleared out all the rules and started over again. It also disabled the import/export of settings, whether “import” or “import as” was used. Fix would be to tag exports with new format indicator, not allow import of others in latest version if format had been updated. Or fix the import routine.

  1. 32 bit
  2. Vista Ultimate
  3. Avast!
  4. Go to miscellaneous/manage my configuration/import and import 3.0.16 settings, then select them. Settings show up as blank, and export/import stops working
  5. Tried it with both an update (answering yes to new format), and again with a clean install
  6. Default for 3.0.0.17; train with safe mode, clean PC
  7. No spontaneous reboot or bsod

After upgrading to 3.0.17.304 all prevous Protected Registry Keys in Defense+ disappeared
completely. Left is a number of blank lines.
Note that the migration wizard was ran to the end without any error messages but not a single
user entry was migrated. Left was the original Comodo entries such as after a clean install but
the Protected registry Keys was gone.

Is there any way to get the default keys provided by Comodo back? At least it would be nice
to get a screen copy so I could add these manually.

Hope on for the best, thanks.

[attachment deleted by admin]

ei4ia: Thanks for your post. (:HUG)

Obviously something happened during the migration from 3.0.16.295 to 3.0.17.304. The migration
never gave any error messages but somthing went wrong.

Now, 4 hours later, I have done a clean install and everything looks ok again.

So far I have taken backups regularly but from now there will be a second backup with copy/paste to “paper” or perhaps I consider something else…

I exported rules from the CFP 3.0.16.295 before I install the new 3.0.17.304 version of CFP, but I can’t import even if it says completed succesfully. Application rules come empty. :frowning:

same here. now more days and hours making this app secure to my taste and relatively silent running.

CFP configurations are symply registry hives that is bynary .reg files so there is no way to tell that a configuration comes from an old version.

I got this issue too but I don’t have an old config to let devs to reproduce this issue.
If anyone passes by and has an old config to attach here it would be appreciated.

Here are a couple of mine-one from .295 and one from .277, The .295 is the one I actually tried to import that corrupted the new settings. .295 file sent directly to bug reporting system.