Websites display black

Every website gives a black screen trying to open the websites source code gives a black screen inside their too. Settings menu works just fine though. And new tab to select pages or plugins also work as the should.

I reinstalled comodo (removed all extensions, all userdata and even uninstalled it with comodo program manager) but none of that fixed the issue.
I’m having this issue since last update and downgrading doesn’t seem to help either.

Comodo Dragon Version (Stable/Beta) (Stable)
Plugins/Themes installed in Comodo Dragon None
Windows version (w/ 32 or 64-bit): Windows 7 Home (64-bit)
UAC status (disabled/enabled) enabled
System Drive where Windows is installed [b]C:[/b]
Place (installation path) where Comodo Dragon is installed
“C:\Program Files (x86)\Comodo\Dragon\dragon.exe”
User privileges administrator
If you have Google Chrome installed not installed

[attachment deleted by admin]

Hi and welcome Roelmb,
Thanks for the good bug report. :slight_smile:
I know you said you have tried by removing Dragons User Data, but do you mean Browsing Data or Dragons User profile?
The reason I ask is to me it sounds like a possible corrupt User Profile in Dragon.
To create a new user profile in Comodo Dragon

You could also try the portable version, this will help eliminate any user profile issues.
The portable version will not effect your installed version.
Portable Version

Thank you.


Please see the reply i gave in this post, it could be the same issue.
Let us know if the suggested workaround works for you.


Thanks George-Silviu Blendea that last thing worked for me :slight_smile:

Seemingly its not completly fixed with that :frowning:
Most of the websites display correctly but some still don’t…
For example:

Doesn’t work while facebook, google, wikipedia, … do work
Most pages do work but some still don’t

Just out of curiosity are your graphics drivers up to date?
I noticed downgrading did not help, has there been any other recent system changes?

None that I know off


Doesn’t work either :confused:
Maybe the websites have something incommon that triggers the fail in loading…

The weird thing is that my mousepointer still changes and links can still be clicked
And sometimes the page loads a split second and then dissapears

I also deleted the total userdata folder without succes

hi, i had the same issue. At first i though an extension is the problem so i uninstalled everything.
Also i tried deleting all the user data. didn’t work.
I then unchecked all the options inside the “settings” tab until i found out that what was causing the black issue is this:
under “show advanced settings”
then “system”
there is an option “Use hardware acceleration when available”
so obviously my hardware is not compatible with the browser but now everything is working as it should be.