-2 Unrecognised argument

I searched google but got one topic directed to here but was solved and closed withouth explanation
I signed up for a free secure email
got an email saying

Simply click on the button below to collect your certificate

clicking on it just takes me to a page with this error

Unrecognised argument!

Can’t figure it out

ُstill have the same problem any help please?

Hi, irkr

We are working on this issue now.
Can you answer me next questions:

  1. The way You have ordered your Comodo Certificate (Web or Comodo SecureEmail sign-up Wizard)?
  2. What browser do you have setup as default (the browser which will start if you click any hyperlink)?
  3. Have you seen the form on the installation certificate page and can you try to fill it with info from your collection e-mail?

Thanks in advance.

Regards, Eugene

  1. not sue wizard perhaps. I installed your program then I went for certificate
  2. IE 7
  3. I just click on the link and I get error.
    Not sure. it is now some time that I have it please give me feed back if solved


Hi Irkr,

Do you still has this issue with version?

Thanks for your latest answer.

Regards, Eugene.

Hi to all,

This issue has been fixed for all new certificate orders.
If you wish to install already ordered certificate you have to find your received Collection Certificate e-mail and follow next steps:

  1. Navigate to: https://secure.comodo.com/products/!SecureEmailCertificate_Collec2
    2 )Fill your e-mail address field
  2. Copy your “Collection Code” from your e-mail and fill proper field on the page.
  3. Accept certificate installation.

I hope this information will help to resolve all your issues.
Feel free to ask me any questions about CSE.

Regards, Eugene.


Can you confirm whether or not the latest version has resolved your issue?