Problem with Active Sync and Windows Mobile 5.0 device


I have had a mobile device that used Windows CE 4.2 and it worked fine with Comodo firewall making sure that the network zone was trusted.
I then changed my mobile device to a PDA that ran Windows Mobile 5.0
I am using the latest Active Sync (4.5) which connects great to the unit when it is docked without Comodo running.
When Comodo is running I will define a trusted network for the Windows Mobile Device (as Comodo sees it) and to a allow it to connect in the entire range of IP addresses that are needed.
IF the PDA is already connected it will continue to work fine with Comodo running. However if I then undock the PDA and then attach it again to the cradle I notice the network icon in the system tray indicating that it is trying to assign an IP address but it will fail.
If I change the IP address of the network connection from dynamic to the one that it will use (and within the permitted IP range defined in Comodo) it still will not work.
Closing Comodo down and all is fine.

Comodo will work fine with the defined network zone of my NVidia controller on the motherboard for my Ethernet connection to my router for my Internet connection. But it causes the errors noted above when tried with my PDA.

Any ideas what could be wrong…?

Thanks for the 15 or so views and I guess that the question was too difficult to answer… (:SAD)

Back to my other firewall which works fine with my combination of PDA and Internet sorry to lose Comodo…

Best wishes (:WAV)

Vimes, I am sorry that no one responded to your initial post. We (volunteers) try to respond within 24 hours, but obviously you got overlooked.

Your problem should not be too difficult to resolve, if you are willing to give it a go, and provide some necessary information. It is probably being blocked because CFP only allows by default, authorized connections; if an application (even one allowed by the Application Monitor) tries to connect in a way that isn’t explicitly allowed by the Network Monitor rules, it will be blocked.

The Activity Logs would probably hold the key information there.



Thanks for the offer of help, much appreciated :slight_smile:

I have just noticed that RC 2 is out and so…

I removed my previous firewall, as I would have done normally. I then installed RC 2 of Comodo with my PDA plugged in and synchronised with my PC.
When Comodo had finished rebooting my PC I get the usual messages about allowing communication between my PC and the PDA and I accepted and this time…

It worked…!!!

Not only did it work, been there before, but when I undock the PDA and then re-dock it it then searches for an IP address, assigns it and then communicates fine as the trusted zone is accpeted, like it was last time.

Not sure what has changed with RC 2 or it could have been that I installed Comodo with the PDA attached, all I know is at the moment all is well.

So thanks again for your generous offer to help me but hopefully all should now be fine (:CLP) (:CLP) (:CLP)

Well, very good, Vimes, I’m glad to hear you’re back, and using RC2 without problems.

I’m confident the ActiveSync problem with could’ve been solved, but hey - fixed is fixed. ;D