BETA. Problem deleting folders

I reported this with the last beta.

It seems that when I uninstall something on my machine and then delete the left over folder of that particular program I get an access denied message. I tried various unlocker programs but nothing seems to be locked and even the unlocker programs can’t delete the folder.

The ways around this is to either reboot my machine or I can kill CPF.EXE and CMDAGENT.EXE and then delete the folder. This is what leads me to believe CPF is the culprit.

This problem seems to follow on the heels of a program uninstall. I can’t recall having this problem deleting a folder not involved with an uninstall. Also I don’t think this happens 100% of the time. I recall being able to delete a folder after an uninstall on occasion.

My problem is not a situation in which a reboot is needed to delete the folder. This is borne out by the fact that when I completely kill CPF I can delete the folder.

Seems that CPF might be ‘holding’ on to the folder even though the tools I have show nothing has it.

I have also seen this a couple of times.

On the next reboot of the computer, I can delete any of the files/folders I need to.

Misery loves company. At least I am not alone on this one.

Seems that most of the problems I am having with CPF is not with it’s handling of security but its screwing up little things in Windows like this problem.

Guess I’ll have to wait for the final version. Afterall it’s still a beta.

Thats a weird issue. Because killing CPF.exe should have no effect if this is directly related to CPFs protection mechanism. CPF.exe is just a GUI to show popups and manage configurations. It does not do anything else.

I thought this was related to IE activeX control. Can you tell me a sample application you installed and uninstalled so that I can try to reproduce?


I installed Rocketdock this morning http://www.punksoftware.com/rocketdock . I decided to uninstall it and after the uninstall I noticed the Rocketdock folder was still in Program Files. I tried to delete it but couldn’t.

I don’t think it’s CPF.EXE that is the culprit. It might be CMDAGENT.EXE. If I just kill CPF.EXE I still can’t delete the folder. When I kill CMDAGENT.EXE I can delete it.

Ok now it sounds possible. Let us see if we can reproduce.


I have this issue also, but I came about it in a different way:

When upgrading iTunes the software said it did not have the necessary permissions to access a certain iTunes folder in the program files. I killed the process for cmdagent.exe and cmain.exe and selected retry on the message iTunes displayed. This time it worked fine and installed.


I’ve experienced this a couple times with beta v2.3.2.21 and just now with beta v2.3.3.33. I uninstalled mirc, went to delete the mirc folder and got access denied (see first snapshot below). Couldn’t open the folder either. So I used “Who Lock Me?” to see what had it locked and it was cmdagent.exe (see second snapshot below). Now since CPF protects itself you can’t use “Who Lock Me?” to kill the process so you can’t delete the folder until after a reboot. I haven’t ran mirc in a few months so there’s no rule in CPF for it. I had a couple times in v2.3.2.21 this didn’t happen (don’t remember the app I uninstalled at the time though).

[attachment deleted by admin]

Thank you for the feedback. Got the possible reason. We will fix the issue for the next version.

Ok great. Thanks egemen. :wink:


Nice. :smiley: It never bothered me but I figured I’d contribute my experience to hopefully help the others. I’m just happy to have a FW simple as ZA but much better. Most others (free versions) require some kind of rule config understanding which I suck at. :wink:

Great news egemen!