169.254.15 New network wants to join???

Hi All,

Last night I left my Vista laptop running while Security Essentials finished a full scan. This morning there is a Comodo message on screen…

“New network detected”

My options were…
“I am Home”
“I am not sure what this one was, maybe work, I think”
“I am in a public place.”

I selected “Public” then shut it down.

An IP check shows that IP is reserved by IANA.org with addresses back to ICAAN so it looks like it may be OK.

Can someone please shed some light on this issue on what if anything I should do?


Hi SweetVLX,

This is what’s called the APIPA range APIPA / Zero-configuration networking - Wikipedia
It’s used by Windows if it can’t get an IP addres by DHCP so for some reason it seems your DHCP server (or ISP router etc, which normally holds this function) was unreachable.
If that happens Windows tries to hold network connection and automagically assigns a 169.254 address.

You can go to Firewall, Network Security Policy, Network Zones and remove the 169.254 entry without risk.

Thanks for the detailed reply, much appreciated.

The modem may have re-booted with a power outage during the night, so maybe that’s what triggered it. Out here in the boonies, we get a lot of very short outages, mostly during the night for some reason.

Thanks for putting my mind at ease.

Your welcome

I have a different IP address but the same “I am at Home”, “I am at Work” and “I am at a Public Place” appeared last night.

I couldn’t close it until I shut down my computer and I didn’t choose any of the options. Although my computer is at home, I wasn’t sure whether to choose an option.

It’s not come up since, but if it does, I’ll choose “Home”, but where are the Firewall / Network Security Policy / Network Zones settings?

As long as it starts with 169.254 you have the same issue. Can you please confirm?

My situation of “Join a New Network” is identical to that of SweetVLX, but instead I have this IP address:

Where are the Network Security Policy and Network Zones for the Comodo firewall?

The pop-up has since reappeared.

Okay so you have a ‘normal’ alert for a detected network, you are on 192.168.0.x /24 and the X might change every few times.

If you are on v6, open the GUI, press the green arrow top right and then go to Firewall Tasks, Open Advanced Settings and go to ‘Network Zones’ they should appear there.

I’m on v4.

Should I follow the same Network Zones rule for v4?

Of v4, my brain is failing on me, but it should be somewhere in the Network security policy tabs.
If you don’t use these zones for any rules, they you can safely select ‘do not show alert’ next time.

Zones are only used if you give them manual meaning, just by this alert they don’t do much, specially not in v4.

Any particular reason your still on v4?

I’ve checked “Network Zone” and found that something called “Loopback Zone” is unticked.

I have no idea why I’m still on v4, it’s all too technical for me, as I’m a novice user, but I did read somewhere that v6 should be left alone for now, which is being reserved for future computer usage. This must be in at least the UK or dependent on the ISP.

Having said that, I’ve since checked “Network Connections” and found that both v4 and v6 are ticked, so I don’t know where the above information comes in about v6 being for the future, but I’d rather not change these settings.

Where is the “Network Security Policy” tab?

You can find it here Comodo Help
That shows where it is, and what it does.

Thanks for the link, but it’s very complex and, upon rechecking your instructions to remove the unwanted IP address (which differs from my own ISP’s IP address), this comes up under “Network Zones”:

“Loopback Zone” -

"IP in [ /]

Is it safe to remove the above without affecting my ISP and Firewall settings?

None of the windows in the link show up on my computer.

On reflection, I’m 99% sure that Comodo’s Firewall has ticked “v6”, as I seem to recall it being inactive originally.

Please be aware that when asking for help, people are going to assume you’re asking for help with the latest version, (or at least, verion 5.12) and attempt to give help based on that. As such, the help you receive may be of little use to you.

Oh, right. I hadn’t realized.

If anyone replies, hopefully they’ll see I’m referring to the current Comodo, version 6.

I’ve since also put this into another thread.

On a side note. Why are you using v4? V5 builds further what v4 started while having an almost identical interface.

Version 5.1x has a more refined sandbox, it’s quieter by default and uses a smaller av database format (makes it run lighter).

Version 6 is even quieter than v5 and brings a new interface. The interface is divisive, one loves it or clearly dislikes it. The default settings are very friendly for novice users.

I’m not sure which person you’re replying to, but I use Version 6.

I am using the Optimum Defense option for security, due to being a novice user, as I don’t mind having prompts, but if they’re too technical or ambiguous like those Zone Alarm used to prompt with, I’d be totally confused.

I think the confusion stems from the fact that you said you were using version 4…

Ronny told you where to make some changes in the version 6 GUI, and you said:

Then Ronny asked why you were using version 4, and you said:

Based on those comments, I thought you were using version 4 as well, which is why I made this comment.