100% CPU Usage In cmdagent.exe

I really like CFP v3, I really do, but I’ve been using a secure deletion program called Eraser recently & when using it cmdagent.exe ends up going bonkers & locks up my pc forcing a restart. It has been happening quite a lot, I need to restart about 2-6 times a day. Secure deletion is more of a priority to me than anything else, but I don’t want to get rid of CFP either. I know it is Defence+ causing the problem as shown in the screenshot, the review vault goes mad & starts adding every file on my pc. Here’s the link to the Eraser website: http://www.heidi.ie/eraser/

[attachment deleted by admin]

Just a shot in the dark at a quick solution- can you try the following:
- delete the file PendingList.txt which is located in C:\Documents and Settings\All Users\Application Data\comodo\common\Pending
- reboot
- when the PendingList.txt file gets recreated, mark it as read-only (using Windows Explorer)
- run your eraser program


Doesn’t work! When I did it, it caused CFP to lockup, so I restarted & after restarting CFP doesn’t even load!

EDIT: Just updated to the latest version, so will test it out & see if I still get a problem.

Hi djp2k7

It appears CFP has had a few problems with eraser as it does a lot of file changes and causes a lot of activity with the Defense+. It probably cannot record the changes as fast as eraser makes them.

Have you checked out the threads here


Thanks for the info, but doesn’t really help me to a fix. The second link is to a problem with not being able to right click for explorer, I’m guessing you made a wrong link ???

Sorry for the bad link, I removed it.


Well after testing a bit more with the latest build, it seems the 100% cpu usage is still present at certain times when using eraser. I had thought it had been fixed as I got a lockup & then cmdagent.exe went back to normal & my computer was running stable once again. But I was erasing yesterday evening & had a lockup for at least an hour before I decided to restart, I thought I would give it time to sort itself out, but I wasn’t going to wait 2 hours to see!

The problem was just too much & I have now reverted back to Outpost firewall. I do hope that comodo get this fixed in the next version, if they do then I will switch back, but until a fix is made I won’t be switching.

My guess that this maybe possibly now fixed in the latest version. I’ve not tried the latest build, but reading the changelog:
[b][i]IMPROVED! Pending Files:

  • Defense+ has been modified such that it is not going to report any pending files if it is not in clean PC mode.[/i][/b]
    I will download the latest build later today & test it the best I can for a few hours after I install it. I will post my results here when I have them. Fingers crossed that it is fixed as I really love CFP v3.

I’m using v and have the same problem with cmdagent.exe.

I’ve been using Comodo for ages with no problems until recently, when I started to have trouble with it failing to load automatically at startup. So, following some advice elsewhere in the forum, yesterday I re-installed Comodo in Safe Mode. That solved the auto-loading problem, but now, on the following day, Im getting this cmdagent.exe problem.

Now, all of a sudden I’m getting this problem today with cmdagent.exe locking up my CPU usage at 100%. This must be sorted out.

I’m going to go download the latest version and if that continues to give me the same problem I’ll be changing to another firewall. The Comodo people have really messed up here.

I see you have suspicious attempts. What re they? Look under D+ events. Is Eraser accessing memory? Have you tried putting D+ in training mode? The only time I get a lock up is when Comodo is trying to learn an apps rules. If you remove all entires of Eraser in the firewall and D+ then put the firewall and D+ in training mode and reboot. Use Eraser and and see what happens.

Do not install CPF3 in Safe Mode the drivers do not install properly, you can uninstall in Safe Mode.
If you are having problems installing (Do this Offline) try closing all no windows process including your Antivirus and also Windows Defender (and its Service) if you have it on your system.

Sorry about the dealay in responding. I didnt receive a notification email. I just stumbled on your response.

The thing is, I didn’t install in Safe Mode. I even had the latest version installed that was supposed to have solved this problem, but it didn’t. I got really fed up with it a couple of days ago and removed Comodo from my PC - even the ununstall didn’t work properly so had to clear it manually. I’ve now installed ZoneAlarm on my computer, but have found that even that is not what it was and have already found a couple of issues with that. If I’m forced to give up on ZoneAlarm, I’ll likely do a complete reinstall of Comodo and see how it goes.