100% CPU Usage-I think I found the problem

I'm starting a new thread because I've spent hours trying to figure this out and haven't seen this mentioned,although it might have been.

               I had the oft mentioned problem with 2.4 causing near 100% CPU usage.

Fortunately for me(and probably others) I found that uninstalling Adobe Reader 7.XX did the trick.Whatever was in the last Adobe update caused this on my PC.I didn’t install the update until yesterday and things went downhill from there.
I’ve been meaning to try Foxreader anyway.
I hope this helps.

Thanks for sharing your solution, alkalvin. Adobe components must’ve been loaded when you browsed (Component Monitor).

I already uninstalled Adobe Reader (version 4, very old) and replaced it with Foxit Reader months ago. My case isn’t as serious as the others because it only triggers when browsing web sites, and dies down to 0% when done when the site finishes loading. But it has stabilized for the most part. It only randomly emerges with Monitor OLE Automation option (which a reboot always fixes).

Does it stabilize with Component Monitor ON mode? You don’t have to test this if you don’t want to.

eek!! I turned it on and my CPU pegged.I went back to learnning mode and it backed off and behaved.

edit-- I had to go and try it again and now the problem is back FWIW.

Apparently, On mode forces CFP to performs checks (probably all of them on the BIG Component Monitor list) to see if they are allowed or denied. Now, did cpu rise while you were browsing sites or just simply remaining idle?

It happened immediatly but I probaly had some windows open.

edit-it looks like network monitor is blocking something almost constantly.I’m not sure what it is.It says port unreachable but I suspect that comodo is blocking it so of course it’s unreachable

The only instance of Net Mon eating cpu is with logging (that I know of).

How do I turn it off? Make it stop!!!

edit-the search fucntion returns 47 pages for “disable logging” and when I tried to edit this page I got “Session verification failed. Please try logging out and back in again, and then try again.”

 It's pretty clear this is just some companies side project and they aren't putting any effort into it.I'm trying jetico,this prog is a barely supported mess.Thanks for the help soya but you cant do it alone.To bad,it had potential.


To disable logging, right-click in the Logs window and uncheck the monitor(s) you want.

Sorry to see you go, alkalvin. You’re always welcomed to return. :slight_smile:

I’m sure it will be fixed in future versions.

I may get PO’d but I don’t give up to easily.
I was looking at jeticos v1 and the beta version trying to figure out which one to try.While I was at their forum I had to turn off comodo and eneable XP’s firewall for about 10 minutes.
Then for the heck of it I turned comodo back on (without diasbling logging) and now my CPU is at 2%!
edit- Is their a way to tell what it was blocking?I could just turn the logging off(TY) but I’d like to find out or it will bug me and I’m already a sleep deprived zombie.

Set this file to read-only: C:\Documents and Settings\All Users\Application Data\Comodo\Personal Firewall\Logs[b]Logs.log[/b]. CFP will continue to log events, but the drawback is that it will reset to the last time you set that file to read-only. So it only lasts during CFP’s active session and will essentially be gone once you exit.

edit: You can export your logs to a html file and then search for what was blocked. It could most likely be a bunch of unsolicited inbound connection attempts.

I don’t know how to interpret the logs.It’s just a bunch of different IP’s that were unreachable.Again,I think this might be because comodo itself is blocking them.
They are all 2 hours old though,it seems to have stopped for now but I really,really need to know what is goijng on in order to relax. My PC was locked down tighter than Maximum Security during a prison riot.

hi all,

in regards to the logging, do you really need to log?

also i had the cmdagent issue also and i disabled all of the behavior analysis and it seemed to work, however will that weaken my protection?

and lastly it seems that instead of cmdagent acting up now cpf has gone haywire and is now taking up over 60% of my cpu…and thats an amd 64 3200+ with 1 gig of ram

thanks for all the help

The chances are your seeing ICMP unreachable messages in the log, which are perfectly normal and are due to the default Network Monitor rules.

[quote author=alkalvin lin (CNY)
edit-the search fucntion returns 47 pages for “disable logging” and when I tried to edit this page I got “Session verification failed. Please try logging out and back in again, and then try again.”
Just reload the page, its not a problem, just a timeout.

Yes, it will. Tremendously. Not for inbound; your network monitor is the primary defense on that. However, the ABA is the “big gun” for preventing hijack programs from getting back out. The idea is that the malware will try to use a legitimate (or seemingly legitimate) program to gain internet access. ABA monitors for these possibilities and alerts you to it. So if you turn that off, a malware could ostensibly hijack, say, internet explorer and you wouldn’t know it.

I think I recall reading that some users have had some success by disabling only DLL Injection Monitoring from within ABA, as that relates to the Component Monitor as well. While this is still a decrease in security, it’s more limited, being only one aspect of the ABA.