Author Topic: Please Update Browsers  (Read 3297 times)

Offline Dennis2

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 9391
Re: Please Update Browsers
« Reply #15 on: December 25, 2016, 11:18:11 AM »
Ok, I'm going to finish this thread by saying that I don't want a new browser, just the current ones updated. My original post was simply to ask why Dragon/Chromodo were still on v52. I see no reason why a member of staff/developer couldn't answer that. An honest answer would do just fine. Regarding the other member, I agree with what he has to say.

Anyhow, a Merry Christmas to everyone and we'll see what 2017 brings ;D

:)
I am not criticising your question, it just happens it has been asked numerous times :)

It would be nice to have a answer,  but I afraid it is not going to happen.

You either use it as it is slow updates, and consider what Comodo does to the browser is worth having even though the updates are well behind.

Or you use another browser :)

Sorry I cannot advise you on what to do, it really is up to the individual person to decide.

Dennis

I did search but have not found the post regarding why different browser, with all searches using the right words helps just finding the right ones is the problem :)
Moderator: Aims Forum a friendly place. Any concerns? Please PM me and/or review the Forum Policy 2012Updated.
System: Centos 7.5 x64, APF, HTTPS Everywhere, ABP, NoScript
 Fedora 28 x64, APF, HTTPS Everywhere, ABP

Offline Graham1

  • Comodo's Hero
  • *****
  • Posts: 1890
Re: Please Update Browsers
« Reply #16 on: December 25, 2016, 11:59:28 AM »
I am not criticising your question, it just happens it has been asked numerous times :)

It would be nice to have a answer,  but I afraid it is not going to happen.

You either use it as it is slow updates, and consider what Comodo does to the browser is worth having even though the updates are well behind.

Or you use another browser :)

Sorry I cannot advise you on what to do, it really is up to the individual person to decide.

Dennis

I did search but have not found the post regarding why different browser, with all searches using the right words helps just finding the right ones is the problem :)

Don't worry, I know you're not. I'm just airing my frustrations :). If you don't ask, you don't...

For the time being, I'm using Chrome. Would have been using Chromium (being my main browser in Ubuntu) but there seems to be issues with Privacy Badger so Chrome will do for now. Will I go back to Dragon? Sure I will, when it's updated.

I remember reading the differences between the browsers at the time but didn't buy into the reasons then.

:)
Ubuntu 18.04 LTS | Chromium | uBlock Origin | Privacy Badger | HTTPS Everywhere
https://www.thevenusproject.com | Beyond Politics Poverty and War

Offline yigido

  • Malware Research Group
  • Comodo's Hero
  • *****
  • Posts: 5691
  • COMODO Rocks!
    • Free Comodo Products!
Re: Please Update Browsers
« Reply #17 on: December 25, 2016, 01:07:13 PM »
I can use Dragon even with out-dated core. I can use it in sandbox, so no problem from exploits or other malwares.

But this one really prevents me to use Dragon now..It is not usable browser for me. This is why we need updates for bug-fixes and problems.
Check the changelogs, most of them did not fix bugs or problems..the team just update browsers to already old cores.
Most of time passed, we see no new good feature but WebRTC leak prevent option. It was great.

I hope Dragon will get an update soon with bugfixes  :-TU
COMODO Cloud Antivirus
Firefox Quantum
Encrypt the web! Use HTTPS Everywhere..
Block spying ads and invisible trackers! Use Privacy Badger..

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek