Author Topic: V-3.0.14.276 D+ settings to allow Firefox downloads  (Read 103833 times)

Offline pitzelberger

  • Comodo Family Member
  • ***
  • Posts: 72
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #60 on: January 25, 2008, 09:39:48 AM »
You either have to be very creative to outthink D+ on the FF Exceptions for Protected Files, or else go into Protected Files/Groups and remove the temp file path.  The latter is probably not that great of an idea, as a lot of malware is known to create/change temp files; it's "Protected" by D+ for a reason...

Thanks for replying.

Unfortunately I am afraid no rule can change that behavior.

I made the following experiment (please correct me if I am wrong):

I went to "Computer Security Policy" and set "Firefox" --> "Acess Rights" --> "Protected Files/Folders" --> Allow

So generally firefox is allowed to write wherever he wants. Nevertheless the error still occurs.

As you may see in one of my previous posts, even setting Defense + to "train" or "disable" did not solve the problem.

I have the impression Defense+ is independent of its settings scanning the files. The settings change only its behavior after it detected something.

Offline Little Mac

  • Forum Volunteer
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 6303
  • The Colonel told me to.
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #61 on: January 25, 2008, 09:53:04 AM »
Since you changed the FF rule to Allow access, did you stop and restart v3?  (as in, Exit from the systray icon, then restart from desktop icon)  Or reboot?  Not saying that you should have to, but it might help, if it's not processing rules well on the fly.

If that doesn't work, I would suggest just deleting the FF rule entirely, reboot, run FF and make the same change you mention above, reboot, run FF and try to download.

LM
These forums are focused on providing help and improvement for Comodo products.  Please treat other users with respect and make a positive contribution.  Thanks.
Forum Policy

Offline pitzelberger

  • Comodo Family Member
  • ***
  • Posts: 72
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #62 on: January 25, 2008, 10:00:53 AM »
Since you changed the FF rule to Allow access, did you stop and restart v3?  (as in, Exit from the systray icon, then restart from desktop icon)  Or reboot?  Not saying that you should have to, but it might help, if it's not processing rules well on the fly.

If that doesn't work, I would suggest just deleting the FF rule entirely, reboot, run FF and make the same change you mention above, reboot, run FF and try to download.

LM

OK thanks, I have to try that later, I have here some stuff running and can not reboot at the moment ...

Offline pitzelberger

  • Comodo Family Member
  • ***
  • Posts: 72
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #63 on: January 25, 2008, 12:39:19 PM »
Since you changed the FF rule to Allow access, did you stop and restart v3?  (as in, Exit from the systray icon, then restart from desktop icon)  Or reboot?  Not saying that you should have to, but it might help, if it's not processing rules well on the fly.

If that doesn't work, I would suggest just deleting the FF rule entirely, reboot, run FF and make the same change you mention above, reboot, run FF and try to download.

LM

Hi Little MAc,

I tried both ways you suggested. I did it even more extreme and set everything in Access Rights to "Allow". The problem remains the same.

I am still thinking comodo is independent of its settings scanning the files. the only thing that changes depending on the settings is how it reacts after scanning.

It's a bit like gambling, if comodo is fast enough nothing happens, but if there's a lot of other processes running in the background, especially stuff that as well acesses the files (like indexing services or anti virus) then it may give that error.
« Last Edit: January 25, 2008, 12:46:04 PM by pitzelberger »

Offline beejay

  • Newbie
  • *
  • Posts: 2
    • Done In Style Web Design and Development
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #64 on: January 25, 2008, 04:04:36 PM »
On my Dell Vostro core2duo, this easiest of solutions is what did the trick. Running Kaspersky AV, if that makes a difference.

Quote
Simplest thing to try first is to fix the ftp rule for Web Browser under firewall/advanced/predefined policies.  Go to Web Browser/edit/Allow ftp out/edit and change the rule to allow/tcp/out/any/any/any/any .  Currently the allowed destination port is only port 21, and that usually blocks passive ftp.

Offline jjb3

  • Newbie
  • *
  • Posts: 10
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #65 on: January 29, 2008, 09:53:36 AM »
Cant get firefox download files over here. I always get the "temp file" error. Can you help?

Btw; more users have the same problem, see thread on the firefox forum.
http://forums.mozillazine.org/viewtopic.php?t=620877

Thanks,
Dennis

Offline pitzelberger

  • Comodo Family Member
  • ***
  • Posts: 72
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #66 on: January 29, 2008, 10:28:15 AM »
Cant get firefox download files over here. I always get the "temp file" error. Can you help?

Btw; more users have the same problem, see thread on the firefox forum.
http://forums.mozillazine.org/viewtopic.php?t=620877

Thanks,
Dennis

Hi, unfortunately I can not help, because I have the same problem and so far no solution.

do you run any other programs in the background that are monitoring new files, e.g. antivirus or indexing service?

It seems, the problem comes from comodo accessing the temp exe file created by firefox. the file seems to be locked during that time by comodo. if comodo does not release the file and firefox wants to write again to the file it results in an access violation.

The problem should only occur when you download exe files?

In my case it often helps to wait after the error meesage apeared some seconds, and then to click the same download link again. often it works then fine after a few tries.

Offline JJasper

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 1656
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #67 on: January 29, 2008, 01:36:38 PM »
From my previous posts you can see that for me it was not a CFP problem but a FF problem.  You can test this yourself by temporarily disabling both the firewall and Defense+ and trying to download again.  If it still will not allow downloads and gets the same temp error message then it is not CFP.  This was my case, without CFP enabled at all the problem was still there.

John

Offline pitzelberger

  • Comodo Family Member
  • ***
  • Posts: 72
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #68 on: January 29, 2008, 04:39:50 PM »
From my previous posts you can see that for me it was not a CFP problem but a FF problem.  You can test this yourself by temporarily disabling both the firewall and Defense+ and trying to download again.  If it still will not allow downloads and gets the same temp error message then it is not CFP.  This was my case, without CFP enabled at all the problem was still there.

John

OK, I see what you mean ...
I made some further tests and I found I was wrong when I was posting that the problem goes after exiting CFP. The problem even remains after exiting comodo.

However, the problem is that even after exiting comodo the service "cmdagent.exe" is still running in the background. There is virtually no way to disabled this service, besides manually removing its autorun registry entry. I did this, reboot windows ---> and the problem is gone.
I put "cmdagent.exe" back --> the problem comes back.

Sorry that I so persist that this problem comes from comodo, but I am running CFP since one month now on my PC, and I have this firefox problem since one month. In between I was trying another firewall for one week, and the problem was gone for one week. I think thats evidence enough for me.

Offline jjb3

  • Newbie
  • *
  • Posts: 10
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #69 on: January 29, 2008, 05:44:27 PM »
Hey,

For me the problem just started a few weeks ago. CF and Windows Xp are fully updated.
I'm also running Comodo Antivirus Beta with HIPS disabled (cause of D+).

About disabling CF... Somethimes when you "Save As" or "Open in tab" in FireFox the download will work, so for me its unclear if its a problem of CF.

Hope this can be fixed soon.

Greets,
Dennis

P.S. just an other topic about this (also without solution).
http://forums.comodo.com/bug_reports/cant_download_exe_files_with_firefox_and_kav7_v3014276_x64-t17439.0.html

Offline pitzelberger

  • Comodo Family Member
  • ***
  • Posts: 72
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #70 on: February 01, 2008, 06:01:18 AM »
BTW, I just switched from CFP to PC Tools Firewall + Threatfire; and the firefox problem is history  :BNC

See you (maybe some day after version 3.1 came out  ;))

Offline jjb3

  • Newbie
  • *
  • Posts: 10
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #71 on: February 06, 2008, 05:44:06 AM »
Yesterday Comodo Firewall updated to 3.0.16.295. Problems are gone now  ;D. Hope it stays this way.

Greets,
Dennis

Offline Little Mac

  • Forum Volunteer
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 6303
  • The Colonel told me to.
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #72 on: February 06, 2008, 09:12:52 PM »
Glad to hear that, jjb3!  Hoping right along with you!

LM
These forums are focused on providing help and improvement for Comodo products.  Please treat other users with respect and make a positive contribution.  Thanks.
Forum Policy

Vettetech

  • Guest
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #73 on: February 06, 2008, 09:28:47 PM »
I have never had a problem what so ever usinf Comodo 2.4 and 3.0 with Firefox. Downloads work fine. I also use Flashgot plugin which will allow me to use my Free Download Manager when I need to download big files. Other then that all downloads start and work fine with Comodo 3.0.

Offline VVrath

  • Newbie
  • *
  • Posts: 2
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #74 on: May 11, 2008, 08:57:58 AM »
Hello, Gents. I just thought I'd tell you guys that I had firefox going through this problem... and as it turns out, I had it set to isolated application, not trusted program. Changing that, everything works very smoothly.

 

Seo4Smf 2.0 © SmfMod.Com | Smf Destek