Author Topic: V-3.0.14.276 D+ settings to allow Firefox downloads  (Read 121675 times)

Offline JJasper

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 1655
V-3.0.14.276 D+ settings to allow Firefox downloads
« on: December 12, 2007, 06:29:46 PM »
I am not able to get Firefox to allow downloads with D+ activated.  I have the identical settings in D+ as well as in Network Security Policy for FF as I do for IE7 but it gives me the following message. (see attached photo). 
I have tried reinstalling FF twice.  I have tried various settings for D+.  I have searched for a solution on the forums to no avail.  It does work with D+ disabled, so I know it is not my FF settings. Download works well in IE7.

Has anyone else had this problem and if so how did you get it working?

John

XP Home SP2 32 bit,  Pentium D 3 Ghz, Ram 1 GB,  BOC, CAVS, CFP3, CMF

[attachment deleted by admin]
« Last Edit: December 23, 2007, 06:31:46 PM by JJasper »

Offline gibran

  • Average User
  • Comodo's Hero
  • *****
  • Posts: 5056
  • A bad workman always blames his tools
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #1 on: December 12, 2007, 06:33:53 PM »
You should look at firefox protected files settings and set it to ask. Later you can edit one file in the allowed list to repace the filename with a *
"In the beginning the Universe was created. This has made a lot of people very angry and has been widely regarded as a bad move."- Douglas Adams

sded

  • Guest
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #2 on: December 12, 2007, 07:03:59 PM »
Haven't had the problem, but setting Opera to Installer or Updater made all of the messages go away when I download and execute things.  I am using Free Download Manager with Firefox, and it also works fine with that setting.  There is also still an error in the Predefined Firewall Policies if you are using them-Allow FTP for a Web Browser still only allows port 21, and you need to change it to any.

Vettetech

  • Guest
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #3 on: December 12, 2007, 09:49:06 PM »
I just uninstalled Online Armor and installed the new and improved Comodo 3.0.14.276 and have no problems downloading files. I download everything into My Briefcase. Whatever problem you have I dont believe its Comodo.

Offline JJasper

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 1655
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #4 on: December 12, 2007, 09:58:43 PM »
I changed the browser allow ftp from 21 to any. No better.  Put FF in the protected file settings, it was already set to ask.  Edited the FF protected with a *. Worked  :BNC

Thanks for all your help

John

I will mark this as resolved.
« Last Edit: December 12, 2007, 10:00:22 PM by JJasper »

sded

  • Guest
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #5 on: December 12, 2007, 10:01:43 PM »
Did you import your .273 settings or start over again?

Offline JJasper

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 1655
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #6 on: December 12, 2007, 11:05:45 PM »
I started over.  I wanted to see what differences there was without any leftovers from the previous version.  I guess I found one anyway.

John
« Last Edit: December 23, 2007, 06:32:14 PM by JJasper »

Offline seed.helper

  • Comodo Loves me
  • ****
  • Posts: 105
Re: V-3.0.14.276 D+ settings to allow Firefox downloads [Resolved]
« Reply #7 on: December 23, 2007, 02:38:10 AM »
please what i have to do exactly ?
i have the same problem

i dont understand very well  (:WIN)
« Last Edit: December 23, 2007, 02:44:32 AM by seed.helper »

Offline seed.helper

  • Comodo Loves me
  • ****
  • Posts: 105
Re: V-3.0.14.276 D+ settings to allow Firefox downloads [Resolved]
« Reply #8 on: December 23, 2007, 09:03:29 AM »
anyone please explain me step by step...  :-\

thanks

david

sded

  • Guest
Re: V-3.0.14.276 D+ settings to allow Firefox downloads [Resolved]
« Reply #9 on: December 23, 2007, 09:09:19 AM »
Simplest thing to try first is to fix the ftp rule for Web Browser under firewall/advanced/predefined policies.  Go to Web Browser/edit/Allow ftp out/edit and change the rule to allow/tcp/out/any/any/any/any .  Currently the allowed destination port is only port 21, and that usually blocks passive ftp.

Offline seed.helper

  • Comodo Loves me
  • ****
  • Posts: 105
Re: V-3.0.14.276 D+ settings to allow Firefox downloads [Resolved]
« Reply #10 on: December 23, 2007, 03:01:19 PM »
Simplest thing to try first is to fix the ftp rule for Web Browser under firewall/advanced/predefined policies.  Go to Web Browser/edit/Allow ftp out/edit and change the rule to allow/tcp/out/any/any/any/any .  Currently the allowed destination port is only port 21, and that usually blocks passive ftp.

i will see if the problem disapears and report something !

but why is an eror with so strange and random .exe names ?


thank you

edit: the problem continues  :'(
« Last Edit: December 23, 2007, 03:08:22 PM by seed.helper »

Offline neobubu

  • Newbie
  • *
  • Posts: 6
Re: V-3.0.14.276 D+ settings to allow Firefox downloads [Resolved]
« Reply #11 on: December 23, 2007, 03:11:48 PM »
I had the same problem Friday with .276 on vista x64 and it appeared out of nowhere.. I tried to change rules for firefox and kav, because i thought it was compatibility issue between both applications, but nothing helped, so I gave up. then I decided to re-install comodo and the pop-up disappeared.. go figure..

Offline JJasper

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 1655
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #12 on: December 23, 2007, 06:31:11 PM »
Sorry I haven't been much help to you on this.  I had it fixed as my post above stated but it returned for no apparent reason today.  I checked my settings are still ok.  I will try reintalling firefox to see if that helps.

John

Quote
I will try reintalling firefox to see if that helps.

Made no difference!
« Last Edit: December 23, 2007, 06:51:35 PM by JJasper »

Offline seed.helper

  • Comodo Loves me
  • ****
  • Posts: 105
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #13 on: December 23, 2007, 07:30:58 PM »
Sorry I haven't been much help to you on this.  I had it fixed as my post above stated but it returned for no apparent reason today.  I checked my settings are still ok.  I will try reintalling firefox to see if that helps.

John

Made no difference!

very strange problem !!!!

i have tried various security software and nothing is detected... including anti spywares and anti-trojans

cheers

Offline JJasper

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 1655
Re: V-3.0.14.276 D+ settings to allow Firefox downloads
« Reply #14 on: December 23, 2007, 10:57:52 PM »
Just did a re-install of CFP 3 and it did not make any difference.  This is the only glitch that I have with CFP and I just can't get it to work so that Firefox allows downloads.  Is there some way that I can check what is happening when I click download on FF?  I tried logging when FF rule is fired and the logs say everything is allowed. I have tried allowing the temp\* folder as safe,  I have tried allowing all of FF as safe.  I need some more ideas.

John

Just disabled CFP firewall security and Defense+ and it didn't make any difference.  Must be something wrong with Firefox.  Tried FF version 2.0.0.9 same problem.
« Last Edit: December 24, 2007, 01:32:15 AM by JJasper »

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek