Author Topic: Bug reports moved?  (Read 715 times)

Offline CISfan

  • Comodo's Hero
  • *****
  • Posts: 1806
Bug reports moved?
« on: July 24, 2022, 10:17:33 AM »
May I know the specific reason why the below two bug reports where moved to the "Forum Policy Violation Board"?

Thank you.

AV Suite updated - HIPS rules got destroyed
HIPS Rules - Reverse order after system log on.

Offline CISfan

  • Comodo's Hero
  • *****
  • Posts: 1806
Re: Bug reports moved?
« Reply #1 on: July 25, 2022, 07:58:23 AM »
I've posted only one bug report yesterday and soon after that two bug reports ended up in the violation board without an explanation nor a PM as to why these reports violated the rules.
What went wrong?

Offline C.O.M.O.D.O RT

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 917
Re: Bug reports moved?
« Reply #2 on: July 25, 2022, 08:06:17 AM »
Hi CISfan,

Thank you for reporting, we haven't moved these topics to the "Forum Policy Violation Board".
Let me check with the related team and update you.

Thanks
C.O.M.O.D.O RT

Offline CISfan

  • Comodo's Hero
  • *****
  • Posts: 1806
Re: Bug reports moved?
« Reply #3 on: July 25, 2022, 08:40:53 AM »
Hello C.O.M.O.D.O RT,

Thank you.

Offline CISfan

  • Comodo's Hero
  • *****
  • Posts: 1806
Re: Bug reports moved?
« Reply #4 on: July 26, 2022, 08:39:58 AM »
The issue that I reported in my last bug report is no coincidence. I'm able to reproduce it, here's what I did.

1) Restored OS backup image containing previous version of AV suite and CIS 8012 with HIPS rules in place.
2) Started system and logged on to the Windows desktop and just let it idle for a while waiting for the AV suite to start updating its software.
3) After a while the AV suite started updating itself and after just a few minutes it finished its updating process without any issues (note: no reboot needed).
4) I checked the HIPS rules, no problems there, all rules are in place.
5) Kept the system running for some time, did some browsing on the internet, opened up the new AV suite GUI just to have a look at it and closed it and let the system running for some more time.
6) Checked the HIPS rules again, everything fine, all rules are in place.
7) Now I did shutdown the system and did wait a while after it powered down before restarting it again.
8) After logging on to the Windows desktop I waited a while for all tray icons to appear and to become ready.
9) Now I checked the HIPS rules, and I'm sorry to say but all rules were gone.

Please note that I've executed all above steps two times in the past days and exactly the same thing keeps happening, no more HIPS rules at the end.

Allow me to say that this is very frustrating to say the least.

Offline C.O.M.O.D.O RT

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 917
Re: Bug reports moved?
« Reply #5 on: July 26, 2022, 09:24:49 AM »

1) Restored OS backup image containing previous version of AV suite and CIS 8012 with HIPS rules in place.

Hi CISfan,

Are you referring Av suite as other security software or is it a CIS ?

Thanks
C.O.M.O.D.O RT

Offline CISfan

  • Comodo's Hero
  • *****
  • Posts: 1806
Re: Bug reports moved?
« Reply #6 on: July 26, 2022, 09:37:47 AM »
Hi CISfan,

Are you referring Av suite as other security software or is it a CIS ?

Thanks
C.O.M.O.D.O RT

Hello C.O.M.O.D.O RT,

Its other AV software suite (not CIS AV) running alongside with CFW 8012.
Please note that AV software suite is not key to this issue as the issue also happens with other software.

Offline C.O.M.O.D.O RT

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 917
Re: Bug reports moved?
« Reply #7 on: July 26, 2022, 09:48:48 AM »
Hello C.O.M.O.D.O RT,

Its other AV software suite (not CIS AV) running alongside with CFW 8012.
Please note that AV software suite is not key to this issue as the issue also happens with other software.
Hi CISfan,

Thanks for providing the requested information, may i know the other Av suite name ?

Thanks
C.O.M.O.D.O RT

Offline CISfan

  • Comodo's Hero
  • *****
  • Posts: 1806
Re: Bug reports moved?
« Reply #8 on: July 26, 2022, 10:01:39 AM »
Hi CISfan,

Thanks for providing the requested information, may i know the other Av suite name ?

Thanks
C.O.M.O.D.O RT

Hello C.O.M.O.D.O RT,

Sure, other AV suite name is Avira.
The previous version AV suite name is called "Avira Free Antivirus" and it updates to "Avira Free Security".

If interested I can provide screenshots of previous AV suite version number and updated AV suite version number.
For the previous AV suite version number screenshot I have to restore OS backup image (but I have to do that anyway).

Offline C.O.M.O.D.O RT

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 917
Re: Bug reports moved?
« Reply #9 on: July 26, 2022, 10:02:57 AM »
Hello C.O.M.O.D.O RT,

Sure, other AV suite name is Avira.
The previous version AV suite name is called "Avira Free Antivirus" and it updates to "Avira Free Security".

If interested I can provide screenshots of previous AV suite version number and updated AV suite version number.
For the previous AV suite version number screenshot I have to restore OS backup image (but I have to do that anyway).
Hi CISfan,

Thank you for the information, we will check with the team and update you.

Thanks
C.O.M.O.D.O RT

Offline CISfan

  • Comodo's Hero
  • *****
  • Posts: 1806
Re: Bug reports moved?
« Reply #10 on: July 30, 2022, 04:39:19 AM »
CIS 8012 vs CIS V5.12

I restored OS backup image containing previous version of AV suite and CIS V5.12 with HIPS rules in place.
Next I executed exactly the same steps 2-8 from post #4.
The result at step 9 from post #4 now is that HIPS rules are still in place (they get not deleted as with CIS 8012).

So what do I do?
Return to good old V5.12 which is able to keep the HIPS rules?

Offline C.O.M.O.D.O RT

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 917
Re: Bug reports moved?
« Reply #11 on: August 01, 2022, 05:15:31 AM »
CIS 8012 vs CIS V5.12

I restored OS backup image containing previous version of AV suite and CIS V5.12 with HIPS rules in place.
Next I executed exactly the same steps 2-8 from post #4.
The result at step 9 from post #4 now is that HIPS rules are still in place (they get not deleted as with CIS 8012).

So what do I do?
Return to good old V5.12 which is able to keep the HIPS rules?
Hi CISfan,

We are aware of this issue.
The team is working on it.
We will keep you posted.

Thanks
C.O.M.O.D.O RT

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 5358
Re: Bug reports moved?
« Reply #12 on: August 01, 2022, 08:16:23 AM »
And with that locked, stop spamming them with duplicate reports you know they are aware of it and you know the solution to prevent it from happening.
« Last Edit: August 01, 2022, 09:06:48 AM by futuretech »

Offline CISfan

  • Comodo's Hero
  • *****
  • Posts: 1806
Re: Bug reports moved?
« Reply #13 on: August 01, 2022, 09:40:38 AM »
Thank you for unlocking.

I'm fully aware that the bug is a known (long standing) issue and that the team is working on it.
The purpose to report similar issues is to share additional information in order to help the team to gain more insights into the bug and how it can be fixed.

Now here's my additional testing information

- Executed same steps 1-6 from post #4.
7) Disabled HIPS feature "Create rules for safe applications" (unticked).
8) Restarted the system and logged on to Windows Desktop and did wait for all tray icons.
9) Checked the HIPS rules, all fine, HIPS rules in place.
10) Enabled HIPS feature "Create rules for safe applications" again (ticked).
11) Did use the system for a while as I normally would do.
12) Shutdown the system.
13) After a while I started the system again to find out that the rules were gone again despite disabling the "Create rules for safe applications" feature before the system restart of step 8.

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 5358
Re: Bug reports moved?
« Reply #14 on: August 01, 2022, 11:50:00 AM »
So no new relevant information then, you turned it back on so it doesn't matter that it was disabled before, Why are you surprised that rules are gone when you turned the buggy setting back on and then shutdown while it was still enabled? The issue is the same, anytime HIPS rules gets updated specifically creating a new application rule, while the system is in the middle of rebooting or shutting down, the rules will be erased next startup/login. There is nothing more that needs to be said, they know about it and claim to be working on it, either accept that or accept that it will never be fixed and you need to not use the setting which causes the issue.
« Last Edit: August 01, 2022, 11:54:25 AM by futuretech »

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek