Author Topic: Error: cPanel Comodo ModSecurity Rules and 2.9.2 Update  (Read 221 times)

Offline jhawkins002

  • Newbie
  • *
  • Posts: 2
Error: cPanel Comodo ModSecurity Rules and 2.9.2 Update
« on: August 11, 2017, 03:07:43 PM »
Greetings!

We are provisioning a new host and going through the install process for adding Comodo as a ModSecurity rule vendor in cPanel WHM. On August 8th it seems that an EasyApache 4 update patched ModSecurity to 2.9.2, but the Comodo YAML metadata only reports that it supports ModSecurity versions up to 2.9.1. Here is the error which now occurs when installing the Comodo ruleset:

Quote
API failure: The vendor metadata does not contain an entry for your version of ModSecurity, “2.9.2”. The only versions of ModSecurity this rule set supports are “2.7.5”, “2.7.7”, “2.8.0”, “2.9.0”, and “2.9.1”.

I believe the YAML data just needs to be updated to reflect the rule's support for the new ModSecurity update.

EasyApache 4 Changelog: https://documentation.cpanel.net/display/EA4/EasyApache+4+Change+Log


Offline jhawkins002

  • Newbie
  • *
  • Posts: 2
Re: Error: cPanel Comodo ModSecurity Rules and 2.9.2 Update
« Reply #1 on: August 12, 2017, 09:25:20 AM »
Just touching back here to report that we have submitted a ticket with Comodo support to look into this issue. I'll return here with any updates as we have them.

Offline linux4me

  • Newbie
  • *
  • Posts: 20
Re: Error: cPanel Comodo ModSecurity Rules and 2.9.2 Update
« Reply #2 on: August 15, 2017, 12:03:35 PM »
It looks like this issue not only causes a problem with new intstallations, but also prevents the vendor rules from being automatically updated:
Code: [Select]
[2017-08-15 02:43:36 -0400] warn [modsec_vendor] The system failed to update the vendor from the URL “https://waf.comodo.com/doc/meta_comodo_apache.yaml”: The vendor metadata does not contain an entry for your version of ModSecurity, “2.9.2”. The only versions of ModSecurity this rule set supports are “2.7.5”, “2.7.7”, “2.8.0”, “2.9.0”, and “2.9.1”. at /usr/local/cpanel/scripts/modsec_vendor line 168.

Offline snewtonge

  • Newbie
  • *
  • Posts: 7
Re: Error: cPanel Comodo ModSecurity Rules and 2.9.2 Update
« Reply #3 on: August 15, 2017, 03:50:28 PM »
Any update on this?

Offline vadim

  • Moderator
  • Comodo's Hero
  • *****
  • Posts: 334
Re: Error: cPanel Comodo ModSecurity Rules and 2.9.2 Update
« Reply #4 on: August 16, 2017, 02:26:05 AM »
New rule set for ModSecurity v.2.9.2 has been added for Comodo ModSecurity Vendor in cPanel:


2.9.2:
  MD5: fc9b07c45d55db64a097d5fbf63b6f9c
  SHA512: 0b91ee55427f9bfa0aa4d918187926b3a04a1d966525cdcd9046ab4cc877d79591980deb88f9cd58f58fd0f2b1e8d5067a6c4cf681b2b3cbb22e6ca179cd3dc5
  distribution: comodo-apache-1133
  url: https://waf.comodo.com/api/cpanel_apache_vendor
--
Vadim Lvovskiy
Development Manager
COMODO Group Inc.

 

Seo4Smf 2.0 © SmfMod.Com Smf Destek