Author Topic: inbound/outbound does not show virtual machine connections  (Read 400 times)

Offline Fpetkey

  • Newbie
  • *
  • Posts: 5
The Comodo installed on my host computer can always show the inbound/outbound connection of the virtual system running in VMware. But I just noticed recently that it does not show anymore. Can anyone help? Thanks.

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 4333
Re: inbound/outbound does not show virtual machine connections
« Reply #1 on: May 26, 2019, 11:40:38 AM »
You need to make sure the Comodo Firewall driver is both listed and enabled with a check box in the network adapter properties. If if is not listed then the driver is not compatible with the adapter.

Offline Fpetkey

  • Newbie
  • *
  • Posts: 5
Re: inbound/outbound does not show virtual machine connections
« Reply #2 on: May 26, 2019, 04:06:55 PM »
Thanks for your reply.
Do you mean it needs to be in the VMware network adapter properties as well? It has been working all the time until recently, so is there a way to add it back to the list? I recently updated the firewall I'm not sure if it's related.   
« Last Edit: May 26, 2019, 04:15:55 PM by Fpetkey »

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 4333
Re: inbound/outbound does not show virtual machine connections
« Reply #3 on: May 26, 2019, 04:53:19 PM »
Yes it needs to be listed and enabled for whichever adapter VMWare is using for the VM depending on how you set up networking for that VM. It would be much easier to re-install CIS as it will add the firewall driver for each compatible adapter. But if you wish to manually do it then you need to click install within the network adapter properties and then select service and look for comodo internet security firewall driver.

Offline Fpetkey

  • Newbie
  • *
  • Posts: 5
Re: inbound/outbound does not show virtual machine connections
« Reply #4 on: May 26, 2019, 09:06:57 PM »
I tried re-install and it's still not working. I tried to add it manually to the list but it doesn't show when I click install. Does it mean somehow it's not supported suddenly?

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 4333
Re: inbound/outbound does not show virtual machine connections
« Reply #5 on: May 27, 2019, 05:06:15 PM »
No something is wrong as it wouldn't be supported all of a sudden, what version of VMWare are you using and which OS? Also which adapter are you checking from VMware?

Offline Fpetkey

  • Newbie
  • *
  • Posts: 5
Re: inbound/outbound does not show virtual machine connections
« Reply #6 on: June 01, 2019, 01:27:46 AM »
I'm using VMWare workstation pro 15.1 and Windows 7 (both host and vm). I checked the local area connection adapter (which has comodo driver) and VMware network adapter (which doesn't have the comodo driver) as shown in the pictures.

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 4333
Re: inbound/outbound does not show virtual machine connections
« Reply #7 on: June 01, 2019, 04:34:43 PM »
Looks like VMWare changed the adapter type which isn't compatible with the firewall driver, so you were updated to a newer VMWare workstation, I do know that the firewall driver is enabled in the virtual adapters in v12 of VMWare workstation.

Offline Fpetkey

  • Newbie
  • *
  • Posts: 5
Re: inbound/outbound does not show virtual machine connections
« Reply #8 on: June 01, 2019, 05:45:38 PM »
Ah... thanks

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek